summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHermann von Kleist2020-05-14 00:39:29 +0200
committerHermann von Kleist2020-05-14 00:39:29 +0200
commitdc56bfb941340c05655252af268b1f1a8ea6ba3d (patch)
treede3243fe6a8e49518af63b993a6d63412ca3a33f
parent389a064fca53f9dfec087401cd82b1d8ebf7b1dc (diff)
downloadaur-dc56bfb941340c05655252af268b1f1a8ea6ba3d.tar.gz
Updated to 0.8.3
Include patch to fix a build issue. See https://github.com/ros/catkin/pull/1090
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f86a5b61873a..9871ba2157a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ros-noetic-catkin
pkgdesc = ROS - Low-level build system macros and infrastructure for ROS.
- pkgver = 0.8.1
+ pkgver = 0.8.3
pkgrel = 1
url = https://www.wiki.ros.org/catkin
arch = any
@@ -16,8 +16,10 @@ pkgbase = ros-noetic-catkin
depends = gmock
depends = python
depends = ros-build-tools-py3
- source = ros-noetic-catkin-0.8.1.tar.gz::https://github.com/ros/catkin/archive/0.8.1.tar.gz
- sha256sums = c7b4a696fd85f7c99714c28d13409a5ed1eb87686ededa5fc80c28d4bae5d698
+ source = ros-noetic-catkin-0.8.3.tar.gz::https://github.com/ros/catkin/archive/0.8.3.tar.gz
+ source = https://patch-diff.githubusercontent.com/raw/ros/catkin/pull/1090.patch
+ sha256sums = 08b3bb22025f4ba5588136e2938e014000fef61339d678070e72a7c5e5e5913d
+ sha256sums = aa8e19489b8056eafd24113308aed773b01e39d0ed6f67cacb94a821bc8c75f7
pkgname = ros-noetic-catkin
diff --git a/PKGBUILD b/PKGBUILD
index 4d00ddda5221..90e4b88d5789 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@ pkgdesc="ROS - Low-level build system macros and infrastructure for ROS."
url='https://www.wiki.ros.org/catkin'
pkgname='ros-noetic-catkin'
-pkgver='0.8.1'
+pkgver='0.8.3'
arch=('any')
pkgrel=1
license=('BSD')
@@ -33,8 +33,15 @@ depends=(
)
_dir="catkin-${pkgver}"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/catkin/archive/${pkgver}.tar.gz")
-sha256sums=('c7b4a696fd85f7c99714c28d13409a5ed1eb87686ededa5fc80c28d4bae5d698')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/catkin/archive/${pkgver}.tar.gz"
+ "https://patch-diff.githubusercontent.com/raw/ros/catkin/pull/1090.patch")
+sha256sums=('08b3bb22025f4ba5588136e2938e014000fef61339d678070e72a7c5e5e5913d'
+ 'aa8e19489b8056eafd24113308aed773b01e39d0ed6f67cacb94a821bc8c75f7')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ patch -p1 < ${srcdir}/1090.patch
+}
build() {
# Use ROS environment variables.