summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-13 19:47:23 +0100
committerGonçalo Camelo Neves Pereira2018-05-13 19:47:23 +0100
commitbc1bffba98b2c1b50e64f24e26bf97d24338ec02 (patch)
treeadf4c1faa4317a3bd20e262af7d8c6451bbce85e
downloadaur-bc1bffba98b2c1b50e64f24e26bf97d24338ec02.tar.gz
Update
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD62
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11d5ca2b7950
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ros-melodic-desktop-full
+ pkgdesc = ROS - A metapackage to aggregate several packages.
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-desktop
+ depends = ros-melodic-simulators
+ depends = ros-melodic-perception
+ depends = ros-melodic-urdf-sim-tutorial
+ source = ros-melodic-desktop-full-1.4.0-0.tar.gz::https://github.com/ros-gbp/metapackages-release/archive/release/melodic/desktop_full/1.4.0-0.tar.gz
+ sha256sums = 5885269074135543abb6814fc97335a4411a12cc716661aa3401186beec6fdc7
+
+pkgname = ros-melodic-desktop-full
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e1cab166eb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - A metapackage to aggregate several packages."
+url='http://www.ros.org/'
+
+pkgname='ros-melodic-desktop-full'
+pkgver='1.4.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-desktop
+ ros-melodic-simulators
+ ros-melodic-perception
+ ros-melodic-urdf-sim-tutorial)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/desktop_full/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/metapackages-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="metapackages-release-release-melodic-desktop_full-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/metapackages-release/archive/release/melodic/desktop_full/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('5885269074135543abb6814fc97335a4411a12cc716661aa3401186beec6fdc7')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}