summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-13 19:47:02 +0100
committerGonçalo Camelo Neves Pereira2018-05-13 19:47:02 +0100
commit4909e608744e7b311dace7849ba0d1b51185df53 (patch)
tree74306000c8d6e4078df9adb3a7347874b0532dee
downloadaur-4909e608744e7b311dace7849ba0d1b51185df53.tar.gz
Update
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD60
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..794b9c79eed4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ros-melodic-dynamic-edt-3d
+ pkgdesc = ROS - The dynamicEDT3D library implements an inrementally updatable Euclidean distance transform (EDT) in 3D.
+ pkgver = 1.9.0
+ pkgrel = 2
+ url = http://octomap.github.io
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-octomap
+ depends = ros-melodic-octomap
+ depends = ros-melodic-catkin
+ source = ros-melodic-dynamic-edt-3d-1.9.0-1.tar.gz::https://github.com/ros-gbp/octomap-release/archive/release/melodic/dynamic_edt_3d/1.9.0-1.tar.gz
+ sha256sums = b3da422d3baebaea5aa422558b878f02058f7695617e5b116ee7bdf1723c12cc
+
+pkgname = ros-melodic-dynamic-edt-3d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cb4951603a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - The dynamicEDT3D library implements an inrementally updatable Euclidean distance transform (EDT) in 3D."
+url='http://octomap.github.io'
+
+pkgname='ros-melodic-dynamic-edt-3d'
+pkgver='1.9.0'
+_pkgver_patch=1
+arch=('any')
+pkgrel=2
+license=('BSD')
+
+ros_makedepends=(ros-melodic-octomap)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-octomap
+ ros-melodic-catkin)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/dynamic_edt_3d/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/octomap-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="octomap-release-release-melodic-dynamic_edt_3d-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/octomap-release/archive/release/melodic/dynamic_edt_3d/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('b3da422d3baebaea5aa422558b878f02058f7695617e5b116ee7bdf1723c12cc')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}