summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-08 14:51:13 +0200
committerGonçalo Camelo Neves Pereira2018-09-08 14:51:13 +0200
commitae497f7455b777330a993dd182e736e490bd50b9 (patch)
tree90222af01ef4bccd461248b87652f33cca0eb938
parent884b04810b6a310ab4b5b07c06436d238128b415 (diff)
downloadaur-ae497f7455b777330a993dd182e736e490bd50b9.tar.gz
Update!
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD113
2 files changed, 72 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 922eb6ddc2a0..dd71a706943e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,21 +8,21 @@ pkgbase = ros-melodic-dynamic-reconfigure
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-melodic-roscpp-serialization
- makedepends = ros-melodic-std-msgs
+ makedepends = ros-melodic-message-generation
+ makedepends = ros-melodic-catkin
makedepends = ros-melodic-rostest
makedepends = ros-melodic-roscpp
- makedepends = ros-melodic-catkin
- makedepends = ros-melodic-message-generation
+ makedepends = ros-melodic-std-msgs
makedepends = boost
- depends = ros-melodic-std-msgs
depends = ros-melodic-message-runtime
- depends = ros-melodic-roscpp
+ depends = ros-melodic-rospy
depends = ros-melodic-roslib
+ depends = ros-melodic-roscpp
depends = ros-melodic-rosservice
- depends = ros-melodic-rospy
+ depends = ros-melodic-std-msgs
depends = boost
- source = ros-melodic-dynamic-reconfigure-1.5.49-1.tar.gz::https://github.com/ros-gbp/dynamic_reconfigure-release/archive/release/melodic/dynamic_reconfigure/1.5.49-1.tar.gz
- sha256sums = 098d99cec81c9f2f2348813e7669374519b6c3ed3af719bf9f449bda3f9e18fc
+ source = ros-melodic-dynamic-reconfigure::git+https://github.com/ros-gbp/dynamic_reconfigure-release.git
+ sha256sums = SKIP
pkgname = ros-melodic-dynamic-reconfigure
diff --git a/PKGBUILD b/PKGBUILD
index 20c49e073f7a..6fbb6a578bd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - This unary stack contains the dynamic_reconfigure package which provides a means to change node parameters at any time without having to restart the node."
url='http://ros.org/wiki/dynamic_reconfigure'
@@ -10,62 +10,77 @@ arch=('any')
pkgrel=2
license=('BSD')
-ros_makedepends=(ros-melodic-roscpp-serialization
- ros-melodic-std-msgs
- ros-melodic-rostest
- ros-melodic-roscpp
- ros-melodic-catkin
- ros-melodic-message-generation)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]}
- boost)
+ros_makedepends=(
+ ros-melodic-roscpp-serialization
+ ros-melodic-message-generation
+ ros-melodic-catkin
+ ros-melodic-rostest
+ ros-melodic-roscpp
+ ros-melodic-std-msgs
+)
-ros_depends=(ros-melodic-std-msgs
- ros-melodic-message-runtime
- ros-melodic-roscpp
- ros-melodic-roslib
- ros-melodic-rosservice
- ros-melodic-rospy)
-depends=(${ros_depends[@]}
- boost)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/dynamic_reconfigure/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/dynamic_reconfigure-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-message-runtime
+ ros-melodic-rospy
+ ros-melodic-roslib
+ ros-melodic-roscpp
+ ros-melodic-rosservice
+ ros-melodic-std-msgs
+)
-# Tarball version (faster download)
-_dir="dynamic_reconfigure-release-release-melodic-dynamic_reconfigure-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/dynamic_reconfigure-release/archive/release/melodic/dynamic_reconfigure/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('098d99cec81c9f2f2348813e7669374519b6c3ed3af719bf9f449bda3f9e18fc')
+depends=(
+ ${ros_depends[@]}
+ boost
+)
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-gbp/dynamic_reconfigure-release.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}