summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-05-24 11:37:44 -0400
committeracxz2020-05-24 11:37:44 -0400
commitc3f684fa95f9a249eeb432445a99b508d66e77e2 (patch)
tree11b9b24f7acf3a9521774220df0e84c3dadb20db
parent263746788e2f47eadbaa5eaa2f4b8424202fd8ee (diff)
downloadaur-c3f684fa95f9a249eeb432445a99b508d66e77e2.tar.gz
upd to noetic, cmake vars, python
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 22 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0327cb6dc5e..a0e7e2f33f26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = ros-melodic-ecl-concepts
+pkgbase = ros-noetic-ecl-concepts
pkgdesc = ROS - Introduces a compile time concept checking mechanism that can be used most commonly to check for required functionality when passing template arguments.
pkgver = 0.62.2
pkgrel = 1
@@ -7,15 +7,15 @@ pkgbase = ros-melodic-ecl-concepts
license = BSD
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-melodic-ecl-license
- makedepends = ros-melodic-ecl-config
- makedepends = ros-melodic-ecl-type-traits
- makedepends = ros-melodic-catkin
- depends = ros-melodic-ecl-license
- depends = ros-melodic-ecl-config
- depends = ros-melodic-ecl-type-traits
- source = ros-melodic-ecl-concepts-0.62.2.tar.gz::https://github.com/stonier/ecl_core/archive/0.62.2.tar.gz
+ makedepends = ros-noetic-ecl-license
+ makedepends = ros-noetic-ecl-config
+ makedepends = ros-noetic-ecl-type-traits
+ makedepends = ros-noetic-catkin
+ depends = ros-noetic-ecl-license
+ depends = ros-noetic-ecl-config
+ depends = ros-noetic-ecl-type-traits
+ source = ros-noetic-ecl-concepts-0.62.2.tar.gz::https://github.com/stonier/ecl_core/archive/0.62.2.tar.gz
sha256sums = 69d503109878e3a2c4f5be611fc9609078714899cae15fbf7f58119fdbd61e37
-pkgname = ros-melodic-ecl-concepts
+pkgname = ros-noetic-ecl-concepts
diff --git a/PKGBUILD b/PKGBUILD
index 8dc386f64e63..4f110f289ca8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,26 @@
pkgdesc="ROS - Introduces a compile time concept checking mechanism that can be used most commonly to check for required functionality when passing template arguments."
url='https://wiki.ros.org/ecl_concepts'
-pkgname='ros-melodic-ecl-concepts'
+pkgname='ros-noetic-ecl-concepts'
pkgver='0.62.2'
arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-ecl-license
- ros-melodic-ecl-config
- ros-melodic-ecl-type-traits
- ros-melodic-catkin)
+ros_makedepends=(ros-noetic-ecl-license
+ ros-noetic-ecl-config
+ ros-noetic-ecl-type-traits
+ ros-noetic-catkin)
makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]})
-ros_depends=(ros-melodic-ecl-license
- ros-melodic-ecl-config
- ros-melodic-ecl-type-traits)
+ros_depends=(ros-noetic-ecl-license
+ ros-noetic-ecl-config
+ ros-noetic-ecl-type-traits)
depends=(${ros_depends[@]})
# Git version (e.g. for debugging)
-# _tag=release/melodic/ecl_concepts/${pkgver}-${_pkgver_patch}
+# _tag=release/noetic/ecl_concepts/${pkgver}-${_pkgver_patch}
# _dir=${pkgname}
# source=("${_dir}"::"git+https://github.com/yujinrobot-release/ecl_core-release.git"#tag=${_tag})
# sha256sums=('SKIP')
@@ -34,24 +34,17 @@ sha256sums=('69d503109878e3a2c4f5be611fc9609078714899cae15fbf7f58119fdbd61e37')
build() {
# Use ROS environment variables
source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
# Create build directory
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
# Build project
cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=-python3.7m \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}