summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchmad Fathoni2021-05-20 02:52:04 +0700
committerAchmad Fathoni2021-05-20 02:52:04 +0700
commit0f20ba3b51cc43bbe5eb6cb0425b46aa83504817 (patch)
treeae02f66115dcc87c49f8ff20ede8e5a2723babff
parentd21604320bc8559c2491bd084e12b2c4125d1e93 (diff)
downloadaur-0f20ba3b51cc43bbe5eb6cb0425b46aa83504817.tar.gz
Change compiler to gcc-10 as CUDA requires it.
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 992eebb68090..7cc6ad976fe4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgdesc="OpenMP boosted NDT and GICP algorithms with CUDA enabled"
url='https://github.com/SMRT-AIST/fast_gicp'
pkgname='ros-noetic-fast-gicp-git'
-pkgver=r125.e1f0863
+pkgver=r127.77a9ac4
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
pkgrel=1
license=('BSD-3-Clause License')
@@ -64,7 +64,9 @@ build() {
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DSETUPTOOLS_DEB_LAYOUT=OFF \
-DBUILD_VGICP_CUDA=$cuda \
- -DCMAKE_CXX_STANDARD=17
+ -DCMAKE_CXX_STANDARD=17 \
+ -DCMAKE_C_COMPILER=gcc-10 \
+ -DCMAKE_CXX_COMPILER=g++-10
}
package() {