summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-05-24 17:39:57 -0400
committeracxz2020-05-24 17:39:57 -0400
commit622b21a2571d944afef3e6e21f50df640e8e2867 (patch)
tree065991e99fd0e865ad951fb29b57137bddd92993
parentf978ebe13013a49f0abf3d4ddebe00183180aab5 (diff)
downloadaur-622b21a2571d944afef3e6e21f50df640e8e2867.tar.gz
remove unneeded patch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--spawn_model.patch84
3 files changed, 6 insertions, 98 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a0c1ea820ca..1d814212c74f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ros-noetic-gazebo-msgs
pkgdesc = ROS - Message and service data structures for interacting with Gazebo from ROS.
- pkgver = 2.8.6
+ pkgver = 2.9.1
pkgrel = 1
url = https://wiki.ros.org/gazebo_msgs
arch = i686
@@ -24,10 +24,8 @@ pkgbase = ros-noetic-gazebo-msgs
depends = ros-noetic-std-srvs
depends = ros-noetic-geometry-msgs
depends = ros-noetic-message-runtime
- source = ros-noetic-gazebo-msgs-2.8.6.tar.gz::https://github.com/ros-simulation/gazebo_ros_pkgs/archive/2.8.6.tar.gz
- source = spawn_model.patch
- sha256sums = df928fbeebd277b8eedf7eb367ab88631de71ef6c552424731eaf855186bc4b4
- sha256sums = a8a83abda169cca6a7709dc618f0b74a270f55ce274ac0108eec5df09f3bb3e8
+ source = ros-noetic-gazebo-msgs-2.9.1.tar.gz::https://github.com/ros-simulation/gazebo_ros_pkgs/archive/2.9.1.tar.gz
+ sha256sums = 9fac7aa1e9773aae20cfef1ec062353f91e4546ebd638e1df2e3f8b51f1e0773
pkgname = ros-noetic-gazebo-msgs
diff --git a/PKGBUILD b/PKGBUILD
index 1371bad08b3a..1aeadd831462 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgdesc="ROS - Message and service data structures for interacting with Gazebo f
url='https://wiki.ros.org/gazebo_msgs'
pkgname='ros-noetic-gazebo-msgs'
-pkgver='2.8.6'
+pkgver='2.9.1'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
pkgrel=1
license=('BSD')
@@ -28,10 +28,8 @@ ros_depends=(ros-noetic-std-msgs
depends=(${ros_depends[@]})
_dir="gazebo_ros_pkgs-${pkgver}/gazebo_msgs"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-simulation/gazebo_ros_pkgs/archive/${pkgver}.tar.gz"
- "spawn_model.patch")
-sha256sums=('df928fbeebd277b8eedf7eb367ab88631de71ef6c552424731eaf855186bc4b4'
- 'a8a83abda169cca6a7709dc618f0b74a270f55ce274ac0108eec5df09f3bb3e8')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-simulation/gazebo_ros_pkgs/archive/${pkgver}.tar.gz")
+sha256sums=('9fac7aa1e9773aae20cfef1ec062353f91e4546ebd638e1df2e3f8b51f1e0773')
build() {
# Use ROS environment variables
@@ -49,10 +47,6 @@ build() {
-DPYTHON_EXECUTABLE=/usr/bin/python \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
-
- # Patch a file after compilation
- cd "${srcdir}/build/devel/lib/python.8/site-packages/gazebo_msgs/srv/"
- patch -uN _SpawnModel.py ${srcdir}/../spawn_model.patch || return 1
}
package() {
diff --git a/spawn_model.patch b/spawn_model.patch
deleted file mode 100644
index 720c302a9862..000000000000
--- a/spawn_model.patch
+++ /dev/null
@@ -1,84 +0,0 @@
---- _SpawnModel.py.orig 2019-12-03 12:29:52.077438274 -0500
-+++ _SpawnModel.py 2019-12-03 12:31:37.704109431 -0500
-@@ -93,19 +93,19 @@
- try:
- _x = self.model_name
- length = len(_x)
-- if python3 or type(_x) == unicode:
-+ if type(_x) == str:
- _x = _x.encode('utf-8')
- length = len(_x)
- buff.write(struct.pack('<I%ss'%length, length, _x))
- _x = self.model_xml
- length = len(_x)
-- if python3 or type(_x) == unicode:
-+ if type(_x) == str:
- _x = _x.encode('utf-8')
- length = len(_x)
- buff.write(struct.pack('<I%ss'%length, length, _x))
- _x = self.robot_namespace
- length = len(_x)
-- if python3 or type(_x) == unicode:
-+ if type(_x) == str:
- _x = _x.encode('utf-8')
- length = len(_x)
- buff.write(struct.pack('<I%ss'%length, length, _x))
-@@ -113,7 +113,7 @@
- buff.write(_get_struct_7d().pack(_x.initial_pose.position.x, _x.initial_pose.position.y, _x.initial_pose.position.z, _x.initial_pose.orientation.x, _x.initial_pose.orientation.y, _x.initial_pose.orientation.z, _x.initial_pose.orientation.w))
- _x = self.reference_frame
- length = len(_x)
-- if python3 or type(_x) == unicode:
-+ if type(_x) == str:
- _x = _x.encode('utf-8')
- length = len(_x)
- buff.write(struct.pack('<I%ss'%length, length, _x))
-@@ -183,19 +183,19 @@
- try:
- _x = self.model_name
- length = len(_x)
-- if python3 or type(_x) == unicode:
-+ if type(_x) == str:
- _x = _x.encode('utf-8')
- length = len(_x)
- buff.write(struct.pack('<I%ss'%length, length, _x))
- _x = self.model_xml
- length = len(_x)
-- if python3 or type(_x) == unicode:
-+ if type(_x) == str:
- _x = _x.encode('utf-8')
- length = len(_x)
- buff.write(struct.pack('<I%ss'%length, length, _x))
- _x = self.robot_namespace
- length = len(_x)
-- if python3 or type(_x) == unicode:
-+ if type(_x) == str:
- _x = _x.encode('utf-8')
- length = len(_x)
- buff.write(struct.pack('<I%ss'%length, length, _x))
-@@ -203,7 +203,7 @@
- buff.write(_get_struct_7d().pack(_x.initial_pose.position.x, _x.initial_pose.position.y, _x.initial_pose.position.z, _x.initial_pose.orientation.x, _x.initial_pose.orientation.y, _x.initial_pose.orientation.z, _x.initial_pose.orientation.w))
- _x = self.reference_frame
- length = len(_x)
-- if python3 or type(_x) == unicode:
-+ if type(_x) == str:
- _x = _x.encode('utf-8')
- length = len(_x)
- buff.write(struct.pack('<I%ss'%length, length, _x))
-@@ -333,7 +333,7 @@
- buff.write(_get_struct_B().pack(self.success))
- _x = self.status_message
- length = len(_x)
-- if python3 or type(_x) == unicode:
-+ if type(_x) == str:
- _x = _x.encode('utf-8')
- length = len(_x)
- buff.write(struct.pack('<I%ss'%length, length, _x))
-@@ -375,7 +375,7 @@
- buff.write(_get_struct_B().pack(self.success))
- _x = self.status_message
- length = len(_x)
-- if python3 or type(_x) == unicode:
-+ if type(_x) == str:
- _x = _x.encode('utf-8')
- length = len(_x)
- buff.write(struct.pack('<I%ss'%length, length, _x))