summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbionade242020-02-15 16:50:18 +0100
committerbionade242020-02-15 16:50:18 +0100
commitfa48d91ec2f0f731d57bf62c4847ea28f750e8a9 (patch)
tree818f5653e8c6335d398a8624f476bf2da410af5b
parent87ca001a202e0bcdc0bd221939e1e804031c01da (diff)
downloadaur-fa48d91ec2f0f731d57bf62c4847ea28f750e8a9.tar.gz
Fixed arch=() array
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4e5449a94eb..a486eeb74772 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,13 @@
pkgbase = ros-melodic-gencpp
pkgdesc = ROS - C++ ROS message and service generators.
pkgver = 0.6.2
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.ros.org/gencpp
- arch = any
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
license = BSD
makedepends = cmake
makedepends = ros-build-tools
diff --git a/PKGBUILD b/PKGBUILD
index 629e4c98fa47..f6d0dfaf6200 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@ url='https://wiki.ros.org/gencpp'
pkgname='ros-melodic-gencpp'
pkgver='0.6.2'
-arch=('any')
-pkgrel=1
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
+pkgrel=2
license=('BSD')
ros_makedepends=(
@@ -50,9 +50,6 @@ build() {
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}