summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:26:36 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:26:36 +0200
commitc1e495a598e7380103e26e439fd10e2ce2b9fc7a (patch)
treed8e98e7e39b36fd9f21a23439c96c6b7f440857e
parent4955bc9ce9439f9189e58e821e0736a8f21e2872 (diff)
downloadaur-c1e495a598e7380103e26e439fd10e2ce2b9fc7a.tar.gz
Update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD101
2 files changed, 47 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 788a44b2bf8c..def5ebadcdab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,15 +8,15 @@ pkgbase = ros-melodic-image-pipeline
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
- depends = ros-melodic-image-proc
depends = ros-melodic-image-view
depends = ros-melodic-image-rotate
depends = ros-melodic-image-publisher
- depends = ros-melodic-stereo-image-proc
depends = ros-melodic-camera-calibration
+ depends = ros-melodic-image-proc
+ depends = ros-melodic-stereo-image-proc
depends = ros-melodic-depth-image-proc
- source = ros-melodic-image-pipeline::git+https://github.com/ros-gbp/image_pipeline-release.git
- sha256sums = SKIP
+ source = ros-melodic-image-pipeline-1.12.23-0.tar.gz::https://github.com/ros-gbp/image_pipeline-release/archive/release/melodic/image_pipeline/1.12.23-0.tar.gz
+ sha256sums = a6e5d39fd81ad438d67124e646c3da415e14afb3d0e59931e0d40433a6c1ea77
pkgname = ros-melodic-image-pipeline
diff --git a/PKGBUILD b/PKGBUILD
index 21b3d2a6b682..13b3df0f2210 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - image_pipeline fills the gap between getting raw images from a camera driver and higher-level vision processing."
url='http://www.ros.org/wiki/image_pipeline'
@@ -10,71 +10,56 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-catkin
-)
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
-)
+ros_depends=(ros-melodic-image-view
+ ros-melodic-image-rotate
+ ros-melodic-image-publisher
+ ros-melodic-camera-calibration
+ ros-melodic-image-proc
+ ros-melodic-stereo-image-proc
+ ros-melodic-depth-image-proc)
+depends=(${ros_depends[@]})
-ros_depends=(
- ros-melodic-image-proc
- ros-melodic-image-view
- ros-melodic-image-rotate
- ros-melodic-image-publisher
- ros-melodic-stereo-image-proc
- ros-melodic-camera-calibration
- ros-melodic-depth-image-proc
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/image_pipeline/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/image_pipeline-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/image_pipeline-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="image_pipeline-release-release-melodic-image_pipeline-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/image_pipeline-release/archive/release/melodic/image_pipeline/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('a6e5d39fd81ad438d67124e646c3da415e14afb3d0e59931e0d40433a6c1ea77')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}