summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-05-27 23:48:36 -0400
committeracxz2020-05-27 23:50:03 -0400
commit012de63f1b6ac6724e86eab4a8ccda56085fe582 (patch)
treeed9cc912b82f0b4acbbc8fc1ea4a2353ce4ba2cc
parent7c911ec5ceb9ba39c00d1ee24522539c3134fa22 (diff)
downloadaur-012de63f1b6ac6724e86eab4a8ccda56085fe582.tar.gz
updpkg
-rw-r--r--.SRCINFO10
-rw-r--r--CMakeLists.patch18
-rw-r--r--PKGBUILD15
3 files changed, 8 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47a0a2488e61..70253749b3f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-noetic-image-view
pkgdesc = ROS - A simple viewer for ROS image topics.
- pkgver = 1.13.0
- pkgrel = 4
+ pkgver = 1.15.2
+ pkgrel = 1
url = https://wiki.ros.org/image_view
arch = i686
arch = x86_64
@@ -36,10 +36,8 @@ pkgbase = ros-noetic-image-view
depends = ros-noetic-image-transport
depends = gtk2
depends = gtk3
- source = ros-noetic-image-view-1.13.0.tar.gz::https://github.com/ros-perception/image_pipeline/archive/1.13.0.tar.gz
- source = CMakeLists.patch
- sha256sums = 3c2309d421acf354ca69a7c814ceec7c8b24732c31a7f1c47a055aedd95cb1c4
- sha256sums = 715e30310dec53eb3d19ef40fb40be48a01a10e3fc170c6ec857ddaa0cea8474
+ source = ros-noetic-image-view-1.15.2.tar.gz::https://github.com/ros-perception/image_pipeline/archive/1.15.2.tar.gz
+ sha256sums = 35427b2d4e1396e0260ea2cf7d770a67104779b65fd03f287082098319c4acf5
pkgname = ros-noetic-image-view
diff --git a/CMakeLists.patch b/CMakeLists.patch
deleted file mode 100644
index bfcb3d2a6551..000000000000
--- a/CMakeLists.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- CMakeLists.txt.orig 2019-09-14 14:45:54.089057224 -0400
-+++ CMakeLists.txt 2019-09-14 14:46:07.352389966 -0400
-@@ -1,12 +1,14 @@
- cmake_minimum_required(VERSION 2.8)
- project(image_view)
-
-+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -isystem /usr/include/harfbuzz")
-+
- find_package(catkin REQUIRED COMPONENTS camera_calibration_parsers cv_bridge dynamic_reconfigure image_transport message_filters message_generation nodelet rosconsole roscpp std_srvs stereo_msgs)
- generate_dynamic_reconfigure_options(cfg/ImageView.cfg)
-
- catkin_package(CATKIN_DEPENDS dynamic_reconfigure)
- find_package(Boost REQUIRED COMPONENTS thread)
--find_package(OpenCV REQUIRED)
-+find_package(OpenCV 3 REQUIRED)
-
- include_directories(${Boost_INCLUDE_DIRS}
- ${catkin_INCLUDE_DIRS}
diff --git a/PKGBUILD b/PKGBUILD
index a0c40219c452..a6052d55412f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@ pkgdesc="ROS - A simple viewer for ROS image topics."
url='https://wiki.ros.org/image_view'
pkgname='ros-noetic-image-view'
-pkgver='1.13.0'
+pkgver='1.15.2'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
-pkgrel=4
+pkgrel=1
license=('BSD')
ros_makedepends=(
@@ -49,15 +49,8 @@ depends=(
)
_dir="image_pipeline-${pkgver}/image_view"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-perception/image_pipeline/archive/${pkgver}.tar.gz"
- CMakeLists.patch)
-sha256sums=('3c2309d421acf354ca69a7c814ceec7c8b24732c31a7f1c47a055aedd95cb1c4'
- '715e30310dec53eb3d19ef40fb40be48a01a10e3fc170c6ec857ddaa0cea8474')
-
-prepare() {
- cd "${srcdir}/${_dir}"
- patch -uN CMakeLists.txt ${srcdir}/CMakeLists.patch || return 1
-}
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-perception/image_pipeline/archive/${pkgver}.tar.gz")
+sha256sums=('35427b2d4e1396e0260ea2cf7d770a67104779b65fd03f287082098319c4acf5')
build() {
# Use ROS environment variables.