summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOskar Roesler2019-09-15 20:06:20 +0200
committerGitHub2019-09-15 20:06:20 +0200
commit6892e10589cfbfc3d62f654c3d72430e9874557d (patch)
tree46f579401dce65163416ee0935b839bc3f94f2b7
parent804d6c5cce183d62264520ca1ac3e3aa360b30f4 (diff)
parent85be4e2fca939639f789ece9959a62259f3636c9 (diff)
downloadaur-6892e10589cfbfc3d62f654c3d72430e9874557d.tar.gz
Merge pull request #9 from acxz/hb.h-patch-fix
Fix build issue (missing hb.h)
-rw-r--r--.SRCINFO6
-rw-r--r--CMakeLists-opencv.patch11
-rw-r--r--CMakeLists.patch18
-rw-r--r--PKGBUILD8
4 files changed, 25 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33d5511f8e62..a517be623ef9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-image-view
pkgdesc = ROS - A simple viewer for ROS image topics.
pkgver = 1.13.0
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.ros.org/image_view
arch = any
license = BSD
@@ -32,9 +32,9 @@ pkgbase = ros-melodic-image-view
depends = ros-melodic-image-transport
depends = gtk2
source = ros-melodic-image-view-1.13.0.tar.gz::https://github.com/ros-perception/image_pipeline/archive/1.13.0.tar.gz
- source = CMakeLists-opencv.patch
+ source = CMakeLists.patch
sha256sums = 3c2309d421acf354ca69a7c814ceec7c8b24732c31a7f1c47a055aedd95cb1c4
- sha256sums = d5525cc488989fbc49e151eccbc790888ec73c781ff1ab43e559e2c70f1b86d3
+ sha256sums = 715e30310dec53eb3d19ef40fb40be48a01a10e3fc170c6ec857ddaa0cea8474
pkgname = ros-melodic-image-view
diff --git a/CMakeLists-opencv.patch b/CMakeLists-opencv.patch
deleted file mode 100644
index a5dc3fbd06e8..000000000000
--- a/CMakeLists-opencv.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.old 2019-06-12 20:01:41.573303352 -0400
-+++ CMakeLists.txt 2019-06-12 20:02:38.589967493 -0400
-@@ -6,7 +6,7 @@
-
- catkin_package(CATKIN_DEPENDS dynamic_reconfigure)
- find_package(Boost REQUIRED COMPONENTS thread)
--find_package(OpenCV REQUIRED)
-+find_package(OpenCV 3 REQUIRED)
-
- include_directories(${Boost_INCLUDE_DIRS}
- ${catkin_INCLUDE_DIRS}
diff --git a/CMakeLists.patch b/CMakeLists.patch
new file mode 100644
index 000000000000..bfcb3d2a6551
--- /dev/null
+++ b/CMakeLists.patch
@@ -0,0 +1,18 @@
+--- CMakeLists.txt.orig 2019-09-14 14:45:54.089057224 -0400
++++ CMakeLists.txt 2019-09-14 14:46:07.352389966 -0400
+@@ -1,12 +1,14 @@
+ cmake_minimum_required(VERSION 2.8)
+ project(image_view)
+
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -isystem /usr/include/harfbuzz")
++
+ find_package(catkin REQUIRED COMPONENTS camera_calibration_parsers cv_bridge dynamic_reconfigure image_transport message_filters message_generation nodelet rosconsole roscpp std_srvs stereo_msgs)
+ generate_dynamic_reconfigure_options(cfg/ImageView.cfg)
+
+ catkin_package(CATKIN_DEPENDS dynamic_reconfigure)
+ find_package(Boost REQUIRED COMPONENTS thread)
+-find_package(OpenCV REQUIRED)
++find_package(OpenCV 3 REQUIRED)
+
+ include_directories(${Boost_INCLUDE_DIRS}
+ ${catkin_INCLUDE_DIRS}
diff --git a/PKGBUILD b/PKGBUILD
index ff289365a3c0..950d9f1ed68a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ url='https://wiki.ros.org/image_view'
pkgname='ros-melodic-image-view'
pkgver='1.13.0'
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(
@@ -51,13 +51,13 @@ depends=(
_dir="image_pipeline-${pkgver}/image_view"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-perception/image_pipeline/archive/${pkgver}.tar.gz"
- CMakeLists-opencv.patch)
+ CMakeLists.patch)
sha256sums=('3c2309d421acf354ca69a7c814ceec7c8b24732c31a7f1c47a055aedd95cb1c4'
- 'd5525cc488989fbc49e151eccbc790888ec73c781ff1ab43e559e2c70f1b86d3')
+ '715e30310dec53eb3d19ef40fb40be48a01a10e3fc170c6ec857ddaa0cea8474')
prepare() {
cd "${srcdir}/${_dir}"
- patch -uN CMakeLists.txt ../../../CMakeLists-opencv.patch || return 1
+ patch -uN CMakeLists.txt ../../../CMakeLists.patch || return 1
}
build() {