summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchmad Fathoni2021-09-27 18:50:31 +0700
committerAchmad Fathoni2021-09-27 18:50:31 +0700
commita98a1f9dffd097a8b558a0f6612d729332b6a801 (patch)
treea6f4daf4dd96fe40a4b756786521ee33fe7764a7
downloadaur-a98a1f9dffd097a8b558a0f6612d729332b6a801.tar.gz
initial commit
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD87
2 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f93b820a80bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = ros-noetic-interactive-slam-git
+ pkgdesc = open source 3D LIDAR-based mapping framework
+ pkgver = r80.b39352f
+ pkgrel = 1
+ url = https://github.com/SMRT-AIST/interactive_slam
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
+ license = GPLv3
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-noetic-catkin
+ makedepends = g2o
+ makedepends = openmp
+ makedepends = pcl
+ makedepends = glfw-x11
+ makedepends = glm
+ depends = ros-noetic-geodesy
+ depends = ros-noetic-pcl-ros
+ depends = ros-noetic-nmea-msgs
+ depends = ros-noetic-hdl-graph-slam-git
+ depends = ros-noetic-odometry-saver-git
+ source = ros-noetic-interactive-slam-git::git://github.com/koide3/interactive_slam.git
+ source = imgui::https://github.com/ocornut/imgui/archive/c077dd4872f435dd959feb024e5a9adb2c7df20c.tar.gz
+ source = portable-file-dialogs::https://github.com/samhocevar/portable-file-dialogs/archive/.tar.gz
+ source = https://github.com/SMRT-AIST/interactive_slam/pull/50.patch
+ source = https://github.com/SMRT-AIST/interactive_slam/pull/51.patch
+ source = https://github.com/SMRT-AIST/interactive_slam/pull/52.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = ros-noetic-interactive-slam-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5706c60d2640
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,87 @@
+# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
+
+pkgdesc="open source 3D LIDAR-based mapping framework"
+url='https://github.com/SMRT-AIST/interactive_slam'
+
+pkgname='ros-noetic-interactive-slam-git'
+pkgver=r80.b39352f
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
+pkgrel=1
+license=('GPLv3')
+
+ros_makedepends=(ros-noetic-catkin)
+makedepends=(
+ cmake
+ ros-build-tools
+ ${ros_makedepends[@]}
+ g2o
+ openmp
+ pcl
+ glfw-x11
+ glm
+)
+
+ros_depends=(
+ ros-noetic-geodesy
+ ros-noetic-pcl-ros
+ ros-noetic-nmea-msgs
+ ros-noetic-hdl-graph-slam-git
+ ros-noetic-odometry-saver-git
+)
+depends=(
+ ${ros_depends[@]}
+)
+
+imgui_hash=c077dd4872f435dd959feb024e5a9adb2c7df20c
+portable_hash=ece1202552b887bb2dc72d0364f5b2069639e53c
+source=(
+ $pkgname::git://github.com/koide3/interactive_slam.git
+ imgui::https://github.com/ocornut/imgui/archive/$imgui_hash.tar.gz
+ portable-file-dialogs::https://github.com/samhocevar/portable-file-dialogs/archive/$portable_hsh.tar.gz
+ https://github.com/SMRT-AIST/interactive_slam/pull/50.patch
+ https://github.com/SMRT-AIST/interactive_slam/pull/51.patch
+ https://github.com/SMRT-AIST/interactive_slam/pull/52.patch
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare(){
+ mv -n imgui-$imgui_hash/* "$pkgname/thirdparty/imgui"
+ mv -n portable-file-dialogs-$portable_hash/* "$pkgname/thirdparty/portable-file-dialogs"
+ cd $pkgname
+ patch --forward --strip=1 --input="${srcdir}/50.patch"
+ patch --forward --strip=1 --input="${srcdir}/51.patch"
+ patch --forward --strip=1 --input="${srcdir}/52.patch"
+}
+
+build() {
+ # Use ROS environment variables
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
+
+ # Build project
+ cmake -Wno-dev -B build -S ${pkgname} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_ENABLE_TESTING=0 \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCMAKE_CXX_STANDARD=17
+ make -sC build
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}/" install
+}