summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-08 14:54:09 +0200
committerGonçalo Camelo Neves Pereira2018-09-08 14:54:09 +0200
commit9d7b6c0b38c1a07a5649e15c6a8df498215bbdbc (patch)
treefd6bf173fb3d51faece0866647540b2bb03d1517
parenta499c210a6685a3c0a68bc69827082b90208f817 (diff)
downloadaur-9d7b6c0b38c1a07a5649e15c6a8df498215bbdbc.tar.gz
Update!
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD115
2 files changed, 73 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68bdd63b522b..26aac94ff69d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,23 +7,23 @@ pkgbase = ros-melodic-laser-geometry
license = BSD
makedepends = cmake
makedepends = ros-build-tools
+ makedepends = ros-melodic-sensor-msgs
makedepends = ros-melodic-tf
- makedepends = ros-melodic-angles
- makedepends = ros-melodic-roscpp
makedepends = ros-melodic-catkin
- makedepends = ros-melodic-sensor-msgs
makedepends = ros-melodic-cmake-modules
+ makedepends = ros-melodic-angles
+ makedepends = ros-melodic-roscpp
makedepends = boost
makedepends = eigen3
- depends = ros-melodic-angles
- depends = ros-melodic-roscpp
depends = ros-melodic-sensor-msgs
+ depends = ros-melodic-roscpp
+ depends = ros-melodic-angles
depends = ros-melodic-tf
- depends = python2-numpy
depends = boost
depends = eigen3
- source = ros-melodic-laser-geometry-1.6.4-0.tar.gz::https://github.com/ros-gbp/laser_geometry-release/archive/release/melodic/laser_geometry/1.6.4-0.tar.gz
- sha256sums = d2c0acb926c14dd2000db4b395b3bbcc26b53fc76461f4cf7c262947e3ed9138
+ depends = python-numpy
+ source = ros-melodic-laser-geometry::git+https://github.com/ros-gbp/laser_geometry-release.git
+ sha256sums = SKIP
pkgname = ros-melodic-laser-geometry
diff --git a/PKGBUILD b/PKGBUILD
index 493eb0ebdd9f..a376d3620d6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - This package contains a class for converting from a 2D laser scan as defined by sensor_msgs/LaserScan into a point cloud as defined by sensor_msgs/PointCloud or sensor_msgs/PointCloud2."
url='http://ros.org/wiki/laser_geometry'
@@ -10,63 +10,78 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-tf
- ros-melodic-angles
- ros-melodic-roscpp
- ros-melodic-catkin
- ros-melodic-sensor-msgs
- ros-melodic-cmake-modules)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]}
- boost
- eigen3)
+ros_makedepends=(
+ ros-melodic-sensor-msgs
+ ros-melodic-tf
+ ros-melodic-catkin
+ ros-melodic-cmake-modules
+ ros-melodic-angles
+ ros-melodic-roscpp
+)
-ros_depends=(ros-melodic-angles
- ros-melodic-roscpp
- ros-melodic-sensor-msgs
- ros-melodic-tf)
-depends=(${ros_depends[@]}
- python2-numpy
- boost
- eigen3)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost
+ eigen3
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/laser_geometry/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/laser_geometry-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-sensor-msgs
+ ros-melodic-roscpp
+ ros-melodic-angles
+ ros-melodic-tf
+)
-# Tarball version (faster download)
-_dir="laser_geometry-release-release-melodic-laser_geometry-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/laser_geometry-release/archive/release/melodic/laser_geometry/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('d2c0acb926c14dd2000db4b395b3bbcc26b53fc76461f4cf7c262947e3ed9138')
+depends=(
+ ${ros_depends[@]}
+ boost
+ eigen3
+ python-numpy
+)
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-gbp/laser_geometry-release.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}