summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:28:15 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:28:15 +0200
commite6d29930164052fe38c87e1ed86fe32c4a287efb (patch)
tree34b0faa1753a9508fe5ece7c7db20ef8f57d4a07
parent2205b48295770ef16bd5049ea0c4c865b56f085d (diff)
downloadaur-e6d29930164052fe38c87e1ed86fe32c4a287efb.tar.gz
Update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD94
2 files changed, 42 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43c0fdf997f2..42a39f1888b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,8 +8,8 @@ pkgbase = ros-melodic-media-export
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
- source = ros-melodic-media-export::git+https://github.com/ros-gbp/media_export-release.git
- sha256sums = SKIP
+ source = ros-melodic-media-export-0.2.0-0.tar.gz::https://github.com/ros-gbp/media_export-release/archive/release/melodic/media_export/0.2.0-0.tar.gz
+ sha256sums = dba5a590101d4f4969a5f963f8fba90fff5a095e0c19770166787d22bdb799e3
pkgname = ros-melodic-media-export
diff --git a/PKGBUILD b/PKGBUILD
index d1c898401c9a..a2d69ff6c0b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - Placeholder package enabling generic export of media paths."
url='http://ros.org/wiki/media_export'
@@ -10,64 +10,50 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-catkin
-)
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
-)
+ros_depends=()
+depends=(${ros_depends[@]})
-ros_depends=(
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/media_export/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/media_export-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/media_export-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="media_export-release-release-melodic-media_export-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/media_export-release/archive/release/melodic/media_export/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('dba5a590101d4f4969a5f963f8fba90fff5a095e0c19770166787d22bdb799e3')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}