summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-08 15:10:31 +0100
committerGonçalo Camelo Neves Pereira2018-05-08 15:10:31 +0100
commitc3c37054479dad9916d457ad269b61eb2d546412 (patch)
tree3511211c1b8d06606742f261f2f749dfaea7948c
downloadaur-c3c37054479dad9916d457ad269b61eb2d546412.tar.gz
Update
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD66
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03a5157aa351
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ros-melodic-nav-msgs
+ pkgdesc = ROS - nav_msgs defines the common messages used to interact with the navigation stack.
+ pkgver = 1.12.6
+ pkgrel = 1
+ url = http://wiki.ros.org/nav_msgs
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-actionlib-msgs
+ makedepends = ros-melodic-message-generation
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-geometry-msgs
+ makedepends = ros-melodic-std-msgs
+ depends = ros-melodic-actionlib-msgs
+ depends = ros-melodic-message-runtime
+ depends = ros-melodic-geometry-msgs
+ depends = ros-melodic-std-msgs
+ source = ros-melodic-nav-msgs-1.12.6-0.tar.gz::https://github.com/ros-gbp/common_msgs-release/archive/release/melodic/nav_msgs/1.12.6-0.tar.gz
+ sha256sums = 96793479de25acdcf228adf9f3662ecf4cc7eb0fcd061d9b27580c7cff2473d3
+
+pkgname = ros-melodic-nav-msgs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b7b7dff8c73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - nav_msgs defines the common messages used to interact with the navigation stack."
+url='http://wiki.ros.org/nav_msgs'
+
+pkgname='ros-melodic-nav-msgs'
+pkgver='1.12.6'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-actionlib-msgs
+ ros-melodic-message-generation
+ ros-melodic-catkin
+ ros-melodic-geometry-msgs
+ ros-melodic-std-msgs)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-actionlib-msgs
+ ros-melodic-message-runtime
+ ros-melodic-geometry-msgs
+ ros-melodic-std-msgs)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/nav_msgs/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/common_msgs-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="common_msgs-release-release-melodic-nav_msgs-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/common_msgs-release/archive/release/melodic/nav_msgs/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('96793479de25acdcf228adf9f3662ecf4cc7eb0fcd061d9b27580c7cff2473d3')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}