summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-05-30 14:55:55 -0400
committeracxz2020-05-30 14:55:55 -0400
commite5c83067243a0cd8f633e6ed1105ed7fc3fa5ace (patch)
tree9f87093349c1155523d5a3c55b39df6f31e889ec
parentf3c84bcb749048a42801577658de75f7151eeee7 (diff)
downloadaur-e5c83067243a0cd8f633e6ed1105ed7fc3fa5ace.tar.gz
fix url
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 5 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63711d4d8051..3f3b35b1ac46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = ros-noetic-octomap
pkgdesc = ROS - The OctoMap library implements a 3D occupancy grid mapping approach, providing data structures and mapping algorithms in C++.
pkgver = 1.9.0
- pkgrel = 4
- url = https://octomaphub.io
+ pkgrel = 5
+ url = http://octomap.github.io
arch = any
license = BSD
makedepends = cmake
diff --git a/PKGBUILD b/PKGBUILD
index 59a55bf7dbb0..37f3a26510e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,12 @@
# Script generated with import_catkin_packages.py
# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - The OctoMap library implements a 3D occupancy grid mapping approach, providing data structures and mapping algorithms in C++."
-url='https://octomaphub.io'
+url='http://octomap.github.io'
pkgname='ros-noetic-octomap'
pkgver='1.9.0'
-_pkgver_patch=1
arch=('any')
-pkgrel=4
+pkgrel=5
license=('BSD')
options=('staticlibs')
@@ -18,13 +17,6 @@ makedepends=('cmake' 'ros-build-tools'
ros_depends=(ros-noetic-catkin)
depends=(${ros_depends[@]})
-# Git version (e.g. for debugging)
-# _tag=release/noetic/octomap/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/octomap-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
-
-# Tarball version (faster download)
_dir="octomap-${pkgver}/octomap"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/OctoMap/octomap/archive/v${pkgver}.tar.gz")
sha256sums=('5f81c9a8cbc9526b2e725251cd3a829e5222a28201b394314002146d8b9214dd')
@@ -42,7 +34,7 @@ build() {
cmake ${srcdir}/${_dir} \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}