summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-10-31 10:59:50 -0400
committerGitHub2019-10-31 10:59:50 -0400
commitd61bf7bd665a61713c7c448293ec70909a7332f1 (patch)
tree18d97e9dec16d5298485fc056c069929adc5b5e2
parentfda121ee1689aef2fb8df100d457819e334fef60 (diff)
parentfef8193211f62ba757c1d1a978b53801f9cef404 (diff)
downloadaur-d61bf7bd665a61713c7c448293ec70909a7332f1.tar.gz
Merge pull request #3 from ros-melodic-arch/src-fix
updated source, move to python3.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD34
-rw-r--r--boost-fix.patch19
3 files changed, 39 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c0644f18e58..af845b31fb4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-ompl
pkgdesc = ROS - OMPL is a free sampling-based motion planning library.
- pkgver = 1.4.0
- pkgrel = 0
+ pkgver = 1.4.1
+ pkgrel = 1
url = https://ompl.kavrakilab.org
arch = any
license = BSD
@@ -11,8 +11,10 @@ pkgbase = ros-melodic-ompl
makedepends = eigen
depends = boost
depends = eigen
- source = ros-melodic-ompl-1.4.0-0.tar.gz::https://github.com/ros-gbp/ompl-release/archive/release/melodic/ompl/1.4.0-0.tar.gz
- sha256sums = 8d4847550f4f212004ee0ec5f07e359297c18df270fe8b964983e80323cd2d43
+ source = ros-melodic-ompl-1.4.1.tar.gz::https://github.com/ompl/ompl/archive/1.4.1.tar.gz
+ source = boost-fix.patch
+ sha256sums = ad3e8e2201772de5e689ba1eee2d845bea1c7f3cdf08de6d282583fbe699856c
+ sha256sums = 41a66f47adc11165278f27c2c565e7e0b37d406c45794383ab8fe1ed6a13cadc
pkgname = ros-melodic-ompl
diff --git a/PKGBUILD b/PKGBUILD
index 334cb409a5b5..8a99a6c1d5d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,9 @@ pkgdesc="ROS - OMPL is a free sampling-based motion planning library."
url='https://ompl.kavrakilab.org'
pkgname='ros-melodic-ompl'
-pkgver='1.4.0'
-_pkgver_patch=0
+pkgver='1.4.1'
arch=('any')
-pkgrel=0
+pkgrel=1
license=('BSD')
ros_makedepends=()
@@ -23,19 +22,15 @@ depends=(${ros_depends[@]}
boost
eigen)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/ompl/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/ompl-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
-
-# Tarball version (faster download)
-_dir="ompl-release-release-melodic-ompl-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ompl-release/archive/release/melodic/ompl/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('8d4847550f4f212004ee0ec5f07e359297c18df270fe8b964983e80323cd2d43')
+_dir="ompl-${pkgver}"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ompl/ompl/archive/${pkgver}.tar.gz"
+ "boost-fix.patch")
+sha256sums=('ad3e8e2201772de5e689ba1eee2d845bea1c7f3cdf08de6d282583fbe699856c'
+ '41a66f47adc11165278f27c2c565e7e0b37d406c45794383ab8fe1ed6a13cadc')
prepare() {
- cd ${srcdir}
+ cd ${srcdir}/${_dir}
+ patch -uN demos/PlannerData.cpp ../../boost-fix.patch || return 1
}
build() {
@@ -48,18 +43,17 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}
diff --git a/boost-fix.patch b/boost-fix.patch
new file mode 100644
index 000000000000..82f8830158cb
--- /dev/null
+++ b/boost-fix.patch
@@ -0,0 +1,19 @@
+--- src/ompl-1.4.1/demos/PlannerData.cpp 2018-12-05 14:01:03.000000000 -0600
++++ ./PlannerData.cpp 2019-10-13 12:42:20.129520443 -0500
+@@ -170,13 +170,15 @@
+ ob::GoalState goal(si);
+ goal.setState(data.getGoalVertex(0).getState());
+ ob::PlannerData::Graph::Vertex start = boost::vertex(data.getStartIndex(0), graph);
++ boost::astar_visitor<boost::null_visitor> dummy_visitor;
+ boost::astar_search(graph, start,
+ [&goal, &opt, &vertices](ob::PlannerData::Graph::Vertex v1) { return distanceHeuristic(v1, &goal, &opt, vertices); },
+ boost::predecessor_map(prev).
+ distance_compare([&opt](ob::Cost c1, ob::Cost c2) { return opt.isCostBetterThan(c1, c2); }).
+ distance_combine([&opt](ob::Cost c1, ob::Cost c2) { return opt.combineCosts(c1, c2); }).
+ distance_inf(opt.infiniteCost()).
+- distance_zero(opt.identityCost()));
++ distance_zero(opt.identityCost()).
++ visitor(dummy_visitor));
+
+ // Extracting the path
+ og::PathGeometric path(si);