summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchmad Fathoni2021-05-15 05:33:36 +0700
committerAchmad Fathoni2021-05-15 05:33:36 +0700
commit9d375e964bb2ac4260b1299e3a8de36589f39d77 (patch)
treead79f649c8ad0a35d1f6ed2966b9c070fe59507e
parent620f19b8b3a0c48d202a6ef6d293f1982e9d345a (diff)
downloadaur-9d375e964bb2ac4260b1299e3a8de36589f39d77.tar.gz
Fix launch target
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81aac5cfaefb..223c2bee9c3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-noetic-onboard-sdk-ros
pkgdesc = ROS interface for the DJI onboard SDK
pkgver = 4.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dji-sdk/Onboard-SDK-ROS
arch = x86_64
license = MIT
@@ -15,6 +15,8 @@ pkgbase = ros-noetic-onboard-sdk-ros
depends = sdl2
depends = opencv
source = https://github.com/dji-sdk/Onboard-SDK-ROS/archive/refs/tags/4.1.0.tar.gz
+ source = https://github.com/dji-sdk/Onboard-SDK-ROS/pull/464.patch
+ sha256sums = 83bb5a30c70c7887a74f0e858e3b6563091ed7a5e58b8f462ea9ec2a9b2639ea
sha256sums = SKIP
pkgname = ros-noetic-onboard-sdk-ros
diff --git a/PKGBUILD b/PKGBUILD
index 034445581f9d..dc28a9531d53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname='ros-noetic-onboard-sdk-ros'
pkgver='4.1.0'
arch=('x86_64')
license=('MIT')
-pkgrel=1
+pkgrel=2
ros_makedepends=(ros-noetic-catkin)
makedepends=(
@@ -25,9 +25,15 @@ depends=(
opencv
)
-_dir="Onboard-SDK-ROS"
-source=("https://github.com/dji-sdk/Onboard-SDK-ROS/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('SKIP')
+_dir="Onboard-SDK-ROS-${pkgver}"
+source=("https://github.com/dji-sdk/Onboard-SDK-ROS/archive/refs/tags/${pkgver}.tar.gz"
+ "https://github.com/dji-sdk/Onboard-SDK-ROS/pull/464.patch")
+sha256sums=('83bb5a30c70c7887a74f0e858e3b6563091ed7a5e58b8f462ea9ec2a9b2639ea' 'SKIP')
+
+prepare() {
+ cd "${_dir}"
+ patch --forward --strip=1 --input="${srcdir}/464.patch"
+}
build() {
# Use ROS environment variables
@@ -35,7 +41,7 @@ build() {
[ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
# Build project
- cmake -B build -S ${_dir}-${pkgver} \
+ cmake -B build -S ${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_ENABLE_TESTING=0 \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \