summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchmad Fathoni2021-08-19 11:25:01 +0700
committerAchmad Fathoni2021-08-19 11:25:01 +0700
commited85fc2d79d2cd386b3f947f15bc7aa1c2971afe (patch)
tree6a9876c83717ea8e9ae1de01545b2bc818fb8a92
parent0af0551aaef2f2eeb9aa1ace2a6be1e9a9eb1736 (diff)
downloadaur-ed85fc2d79d2cd386b3f947f15bc7aa1c2971afe.tar.gz
Fix C++ standard
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3deaafd9c8f1..c05c8159b4ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-noetic-pcl-ros
pkgdesc = ROS - PCL (Point Cloud Library) ROS interface stack.
pkgver = 1.7.2
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.ros.org/perception_pcl
arch = i686
arch = x86_64
@@ -37,4 +37,3 @@ pkgbase = ros-noetic-pcl-ros
sha256sums = 1d131d1897f5380617842805f1aff193071a8104c8994737d32bab8b3caa08a4
pkgname = ros-noetic-pcl-ros
-
diff --git a/PKGBUILD b/PKGBUILD
index 5d831fc86b02..00dad88e432d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ url='https://wiki.ros.org/perception_pcl'
pkgname='ros-noetic-pcl-ros'
pkgver='1.7.2'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(
@@ -61,6 +61,7 @@ build() {
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
-DPYTHON_EXECUTABLE=/usr/bin/python \
+ -DCMAKE_CXX_STANDARD=17 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}