summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-10-18 09:47:14 -0400
committeracxz2020-10-18 09:47:14 -0400
commit7dcebf0ca4115784a7517d8a01274f8fe0392b20 (patch)
tree732116b5be738e24e4a775015c6b2c3550474338
parent312fd51c7bcd0bed139de5287c6e36180cf1e082 (diff)
downloadaur-7dcebf0ca4115784a7517d8a01274f8fe0392b20.tar.gz
use upstream PR sip patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--sip_path.patch17
3 files changed, 6 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c12b2e54d82..dfa5aa84d68d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-noetic-python-qt-binding
pkgdesc = ROS - This stack provides Python bindings for Qt.
pkgver = 0.4.3
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.ros.org/python_qt_binding
arch = any
license = BSD
@@ -12,9 +12,9 @@ pkgbase = ros-noetic-python-qt-binding
makedepends = qt5-base
depends = python-pyqt5
source = ros-noetic-python-qt-binding-0.4.3.tar.gz::https://github.com/ros-visualization/python_qt_binding/archive/0.4.3.tar.gz
- source = sip_path.patch
+ source = sip_path.patch::https://patch-diff.githubusercontent.com/raw/ros-visualization/python_qt_binding/pull/95.patch
sha256sums = e76de1c4a05c59094ccbb37a7bb0e252a6e33e5cc0fed83b41ccf84bc47c39c6
- sha256sums = d60d8edfc7dec99700fd66076d6fd01963a26e7623562c1ef289abc041e8d2ef
+ sha256sums = 07a4fb8dc8f822b5806a757a51584851f7960d05940ca6d9e1256f567cb32759
pkgname = ros-noetic-python-qt-binding
diff --git a/PKGBUILD b/PKGBUILD
index 7d67199f450c..61fc2f79c5d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ url='https://wiki.ros.org/python_qt_binding'
pkgname='ros-noetic-python-qt-binding'
pkgver='0.4.3'
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(
@@ -29,9 +29,9 @@ depends=(
_dir="python_qt_binding-${pkgver}"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/python_qt_binding/archive/${pkgver}.tar.gz"
- "sip_path.patch")
+ "sip_path.patch"::"https://patch-diff.githubusercontent.com/raw/ros-visualization/python_qt_binding/pull/95.patch")
sha256sums=('e76de1c4a05c59094ccbb37a7bb0e252a6e33e5cc0fed83b41ccf84bc47c39c6'
- 'd60d8edfc7dec99700fd66076d6fd01963a26e7623562c1ef289abc041e8d2ef')
+ '07a4fb8dc8f822b5806a757a51584851f7960d05940ca6d9e1256f567cb32759')
prepare() {
cd ${srcdir}/${_dir}
diff --git a/sip_path.patch b/sip_path.patch
deleted file mode 100644
index fa6397eae7f5..000000000000
--- a/sip_path.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff '--color=auto' --unified --recursive --text python_qt_binding-0.3.6/cmake/sip_configure.py python_qt_binding-0.3.6.new/cmake/sip_configure.py
---- python_qt_binding-0.3.6/cmake/sip_configure.py 2019-09-30 23:33:33.000000000 +0200
-+++ python_qt_binding-0.3.6.new/cmake/sip_configure.py 2020-02-11 20:37:31.118114272 +0100
-@@ -58,10 +58,11 @@
- if os.path.exists(default_sip_dir):
- return default_sip_dir, sip_flags
-
-- # Homebrew installs sip files here by default
-- default_sip_dir = os.path.join(sipconfig._pkg_config['default_sip_dir'], 'Qt5')
-+ # arch python3 pkg uses /usr/lib/python3.8/site-packages/PyQt5/bindings directory
-+ default_sip_dir = os.path.join(sipconfig._pkg_config['default_mod_dir'], 'PyQt5', 'bindings')
- if os.path.exists(default_sip_dir):
- return default_sip_dir, sip_flags
-+
- raise FileNotFoundError('The sip directory for PyQt5 could not be located. Please ensure' +
- ' that PyQt5 is installed')
-