summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbionade242020-02-11 20:40:30 +0100
committerbionade242020-02-11 20:40:30 +0100
commitb16300a14f82bca01fa126b2789012b10f35622f (patch)
tree2deccb6b78a8fdda000c912228ce48efe2653e35
parent886969858ca3dd68908b3fdd1ae897c2814649a8 (diff)
downloadaur-b16300a14f82bca01fa126b2789012b10f35622f.tar.gz
Fixed sip_path.patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--sip_path.patch27
3 files changed, 15 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c259a4efea0..7751dc3841a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-python-qt-binding
pkgdesc = ROS - This stack provides Python bindings for Qt.
pkgver = 0.3.6
- pkgrel = 3
+ pkgrel = 4
url = https://wiki.ros.org/python_qt_binding
arch = any
license = BSD
@@ -17,7 +17,7 @@ pkgbase = ros-melodic-python-qt-binding
source = sip_path.patch
sha256sums = b56b8b35f72b8543aab7903eb4e9d456991994a06032a08ba72ba627c6652e12
sha256sums = 0aff7f07a1cdb9b09bbf792c4d79e431c8f4a5ccdd2d5a34168dd0a81ad4beb7
- sha256sums = d80b1e8fb25b557e3508772a388a5f2362b46311e7d8b71d677b2500e6608ff7
+ sha256sums = d60d8edfc7dec99700fd66076d6fd01963a26e7623562c1ef289abc041e8d2ef
pkgname = ros-melodic-python-qt-binding
diff --git a/PKGBUILD b/PKGBUILD
index 5b3f145f4f80..e3f34e5f7b3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ url='https://wiki.ros.org/python_qt_binding'
pkgname='ros-melodic-python-qt-binding'
pkgver='0.3.6'
arch=('any')
-pkgrel=3
+pkgrel=4
license=('BSD')
ros_makedepends=(
@@ -34,7 +34,7 @@ source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/pyt
"sip_path.patch")
sha256sums=('b56b8b35f72b8543aab7903eb4e9d456991994a06032a08ba72ba627c6652e12'
'0aff7f07a1cdb9b09bbf792c4d79e431c8f4a5ccdd2d5a34168dd0a81ad4beb7'
- 'd80b1e8fb25b557e3508772a388a5f2362b46311e7d8b71d677b2500e6608ff7')
+ 'd60d8edfc7dec99700fd66076d6fd01963a26e7623562c1ef289abc041e8d2ef')
prepare() {
cd ${srcdir}/${_dir}
diff --git a/sip_path.patch b/sip_path.patch
index 9f3c76bcbefe..fa6397eae7f5 100644
--- a/sip_path.patch
+++ b/sip_path.patch
@@ -1,22 +1,17 @@
-diff '--color=auto' --unified --recursive --text python_qt_binding-0.3.6.orig/cmake/sip_configure.py python_qt_binding-0.3.6/cmake/sip_configure.py
---- python_qt_binding-0.3.6.orig/cmake/sip_configure.py 2020-01-08 15:48:04.071751480 +0100
-+++ python_qt_binding-0.3.6/cmake/sip_configure.py 2020-01-08 15:54:28.764128505 +0100
-@@ -54,16 +54,11 @@
- # sipconfig.Configuration does not have a pyqt_sip_dir or pyqt_sip_flags AttributeError
- sip_flags = QtCore.PYQT_CONFIGURATION['sip_flags']
-
-- default_sip_dir = os.path.join(sipconfig._pkg_config['default_sip_dir'], 'PyQt5')
-+ # arch python3 pkg uses /usr/lib/python3.8/site-packages/PyQt5/bindings directory
-+ default_sip_dir = os.path.join(sipconfig._pkg_config['default_mod_dir'], 'PyQt5', 'bindings')
+diff '--color=auto' --unified --recursive --text python_qt_binding-0.3.6/cmake/sip_configure.py python_qt_binding-0.3.6.new/cmake/sip_configure.py
+--- python_qt_binding-0.3.6/cmake/sip_configure.py 2019-09-30 23:33:33.000000000 +0200
++++ python_qt_binding-0.3.6.new/cmake/sip_configure.py 2020-02-11 20:37:31.118114272 +0100
+@@ -58,10 +58,11 @@
if os.path.exists(default_sip_dir):
return default_sip_dir, sip_flags
- # Homebrew installs sip files here by default
- default_sip_dir = os.path.join(sipconfig._pkg_config['default_sip_dir'], 'Qt5')
-- if os.path.exists(default_sip_dir):
-- return default_sip_dir, sip_flags
-- raise FileNotFoundError('The sip directory for PyQt5 could not be located. Please ensure' +
-- ' that PyQt5 is installed')
-
++ # arch python3 pkg uses /usr/lib/python3.8/site-packages/PyQt5/bindings directory
++ default_sip_dir = os.path.join(sipconfig._pkg_config['default_mod_dir'], 'PyQt5', 'bindings')
+ if os.path.exists(default_sip_dir):
+ return default_sip_dir, sip_flags
++
+ raise FileNotFoundError('The sip directory for PyQt5 could not be located. Please ensure' +
+ ' that PyQt5 is installed')
- if len(sys.argv) != 8: