summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2023-12-16 20:53:03 -0600
committeracxz2023-12-16 20:53:03 -0600
commitc54bc28e22ef3a62f6e19e21a10beea1602bfac5 (patch)
tree219201380ace0f9a59588565b657de1e5b9c1170
parent2c510940c3ee1f075ca1743308f02b80cc27efc4 (diff)
downloadaur-c54bc28e22ef3a62f6e19e21a10beea1602bfac5.tar.gz
add sip patch from upstream commit
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38c1f6175e8c..0a739407e945 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-noetic-python-qt-binding
pkgdesc = ROS - This stack provides Python bindings for Qt.
pkgver = 0.4.4
- pkgrel = 3
+ pkgrel = 4
url = https://wiki.ros.org/python_qt_binding
arch = any
license = BSD
@@ -12,8 +12,8 @@ pkgbase = ros-noetic-python-qt-binding
makedepends = qt5-base
depends = python-pyqt5
source = ros-noetic-python-qt-binding-0.4.4.tar.gz::https://github.com/ros-visualization/python_qt_binding/archive/0.4.4.tar.gz
- source = sip.patch::https://github.com/ros-visualization/python_qt_binding/pull/105.patch
+ source = sip.patch::https://github.com/ros-visualization/python_qt_binding/commit/7095b4de210e2b235606f73565908f9af413db96.patch
sha256sums = bcb5076226100f901e6a22656cf69ef0e8d5f1845670e6fad6fc5fdcb3a1dd07
- sha256sums = SKIP
+ sha256sums = cd9774272b38183a30275613fd593f0b2de9e18192d2f5c98b26cd4e5cf33d53
pkgname = ros-noetic-python-qt-binding
diff --git a/PKGBUILD b/PKGBUILD
index 27e3943f3d3e..31087443883d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ url='https://wiki.ros.org/python_qt_binding'
pkgname='ros-noetic-python-qt-binding'
pkgver='0.4.4'
arch=('any')
-pkgrel=3
+pkgrel=4
license=('BSD')
ros_makedepends=(
@@ -19,17 +19,23 @@ makedepends=(
qt5-base
)
+ros_depends=(
+)
+
depends=(
+ ${ros_depends[@]}
python-pyqt5
)
_dir="python_qt_binding-${pkgver}"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/python_qt_binding/archive/${pkgver}.tar.gz"
- "sip.patch"::"https://github.com/ros-visualization/python_qt_binding/pull/105.patch")
-sha256sums=('bcb5076226100f901e6a22656cf69ef0e8d5f1845670e6fad6fc5fdcb3a1dd07' SKIP)
+ "sip.patch"::"https://github.com/ros-visualization/python_qt_binding/commit/7095b4de210e2b235606f73565908f9af413db96.patch")
+sha256sums=('bcb5076226100f901e6a22656cf69ef0e8d5f1845670e6fad6fc5fdcb3a1dd07'
+ 'cd9774272b38183a30275613fd593f0b2de9e18192d2f5c98b26cd4e5cf33d53')
prepare() {
- patch --directory="$srcdir/$_dir" --forward --strip=1 --input="$srcdir/sip.patch"
+ cd "$srcdir/python_qt_binding-${pkgver}"
+ patch -Np1 -i "$srcdir/sip.patch"
}
build() {
@@ -42,7 +48,7 @@ build() {
cd ${srcdir}/build
# Build the project.
- cmake ${srcdir}/${_dir} -Wno-dev \
+ cmake ${srcdir}/${_dir} \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
-DPYTHON_EXECUTABLE=/usr/bin/python \