summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-05-24 12:06:22 -0400
committeracxz2020-05-24 12:06:22 -0400
commitf514478fbe8a77fe259f10c9df86a95fdaa9e15b (patch)
treee073f1b1f7f0a3ce36a6eb8ee662f36b388c8a6f
parenta6be40726d757f2ad68d50fa0d721de148b26274 (diff)
downloadaur-f514478fbe8a77fe259f10c9df86a95fdaa9e15b.tar.gz
upd to noetic, cmake vars, python
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4468d5f8d06c..2ea879df72b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = ros-melodic-python-qt-binding
+pkgbase = ros-noetic-python-qt-binding
pkgdesc = ROS - This stack provides Python bindings for Qt.
pkgver = 0.4.1
pkgrel = 1
@@ -7,15 +7,15 @@ pkgbase = ros-melodic-python-qt-binding
license = BSD
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-melodic-rosbuild
- makedepends = ros-melodic-catkin
+ makedepends = ros-noetic-rosbuild
+ makedepends = ros-noetic-catkin
makedepends = python-pyqt5
makedepends = qt5-base
depends = python-pyqt5
- source = ros-melodic-python-qt-binding-0.4.1.tar.gz::https://github.com/ros-visualization/python_qt_binding/archive/0.4.1.tar.gz
+ source = ros-noetic-python-qt-binding-0.4.1.tar.gz::https://github.com/ros-visualization/python_qt_binding/archive/0.4.1.tar.gz
source = sip_path.patch
sha256sums = 1a153e400bb7def3751fffaba379c8689af60553950351eb6ec358e191725fc1
sha256sums = d60d8edfc7dec99700fd66076d6fd01963a26e7623562c1ef289abc041e8d2ef
-pkgname = ros-melodic-python-qt-binding
+pkgname = ros-noetic-python-qt-binding
diff --git a/PKGBUILD b/PKGBUILD
index e9e38b08bf42..f60eda58ecb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
pkgdesc="ROS - This stack provides Python bindings for Qt."
url='https://wiki.ros.org/python_qt_binding'
-pkgname='ros-melodic-python-qt-binding'
+pkgname='ros-noetic-python-qt-binding'
pkgver='0.4.1'
arch=('any')
pkgrel=1
license=('BSD')
ros_makedepends=(
- ros-melodic-rosbuild
- ros-melodic-catkin
+ ros-noetic-rosbuild
+ ros-noetic-catkin
)
makedepends=(
@@ -42,21 +42,17 @@ prepare() {
build() {
# Use ROS environment variables.
source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
# Create the build directory.
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
# Build the project.
cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}