summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-06-27 22:47:13 -0400
committerGitHub2019-06-27 22:47:13 -0400
commit63e99e791293cdf7dcdbde0e181090fb629d76dc (patch)
treeef677293bc6e8186f25e732c315e2f42c07eceb7
parent234e4579a17497178b2834d9ab103d882087bbb7 (diff)
parent963703f9447109754a506bfe905da3ce7d524208 (diff)
downloadaur-63e99e791293cdf7dcdbde0e181090fb629d76dc.tar.gz
Merge pull request #5 from acxz/master
build fix for missing QT env variable
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d020ae1d82e6..2395d04d8970 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-qt-gui-cpp
pkgdesc = ROS - qt_gui_cpp provides the foundation for C++-bindings for qt_gui and creates bindings for every generator available.
pkgver = 0.3.11
- pkgrel = 2
+ pkgrel = 3
url = http://ros.org/wiki/qt_gui_cpp
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index f1d2095288f4..ae6872ce571b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ url='http://ros.org/wiki/qt_gui_cpp'
pkgname='ros-melodic-qt-gui-cpp'
pkgver='0.3.11'
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(
@@ -61,7 +61,14 @@ build() {
-DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
-DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
+
+ make || {
+ # Replace $$[QT_INSTALL_LIBS] with hardcoded /usr/lib/ for proper linking
+ # Relevant issue:
+ # https://github.com/ros-melodic-arch/ros-melodic-qt-gui-cpp/issues/4
+ sed -i 's/$$\[QT_INSTALL_LIBS\]/\/usr\/lib/' ${srcdir}/build/sip/qt_gui_cpp_sip/Makefile
make
+ }
}
package() {