summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-08 15:15:24 +0100
committerGonçalo Camelo Neves Pereira2018-05-08 15:15:24 +0100
commit72d11a6aee76dea9f61a038ee0ab55b82cc4a165 (patch)
tree2e49e24fc2c81d69e6bbff42af1206e3dcf1fddd
downloadaur-72d11a6aee76dea9f61a038ee0ab55b82cc4a165.tar.gz
Update
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD67
2 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca8a25bf4392
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ros-melodic-qt-gui-cpp
+ pkgdesc = ROS - qt_gui_cpp provides the foundation for C++-bindings for qt_gui and creates bindings for every generator available.
+ pkgver = 0.3.8
+ pkgrel = 1
+ url = http://ros.org/wiki/qt_gui_cpp
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-pluginlib
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-python-qt-binding
+ makedepends = ros-melodic-cmake-modules
+ makedepends = tinyxml
+ makedepends = qt5-base
+ makedepends = pkg-config
+ depends = ros-melodic-pluginlib
+ depends = ros-melodic-qt-gui
+ depends = tinyxml
+ source = ros-melodic-qt-gui-cpp-0.3.8-0.tar.gz::https://github.com/ros-gbp/qt_gui_core-release/archive/release/melodic/qt_gui_cpp/0.3.8-0.tar.gz
+ sha256sums = f6129008dbf1dafc98a5a7d419d04b7feed223a3b5dab5d0fde54d81c07a1c11
+
+pkgname = ros-melodic-qt-gui-cpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0b46760ae65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - qt_gui_cpp provides the foundation for C++-bindings for qt_gui and creates bindings for every generator available."
+url='http://ros.org/wiki/qt_gui_cpp'
+
+pkgname='ros-melodic-qt-gui-cpp'
+pkgver='0.3.8'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-pluginlib
+ ros-melodic-catkin
+ ros-melodic-python-qt-binding
+ ros-melodic-cmake-modules)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ tinyxml
+ qt5-base
+ pkg-config)
+
+ros_depends=(ros-melodic-pluginlib
+ ros-melodic-qt-gui)
+depends=(${ros_depends[@]}
+ tinyxml)
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/qt_gui_cpp/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/qt_gui_core-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="qt_gui_core-release-release-melodic-qt_gui_cpp-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/qt_gui_core-release/archive/release/melodic/qt_gui_cpp/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('f6129008dbf1dafc98a5a7d419d04b7feed223a3b5dab5d0fde54d81c07a1c11')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}