summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2021-01-09 14:57:19 -0500
committeracxz2021-01-09 14:57:19 -0500
commit596603f54bf14f5d774d690b838384cc0f3f81ff (patch)
treedb9be2734c993084107eee1eb425873c78eef738
parente04a6413d173521df93d26dba10f5c185eb3746e (diff)
downloadaur-596603f54bf14f5d774d690b838384cc0f3f81ff.tar.gz
updpkg 1.3.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD58
2 files changed, 32 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d21049df257c..e60e1e3d315e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-noetic-ros-tutorials
pkgdesc = ROS - ros_tutorials contains packages that demonstrate various features of ROS, as well as support packages which help demonstrate those features.
- pkgver = 0.9.1
- pkgrel = 3
+ pkgver = 1.3.1
+ pkgrel = 1
url = https://wiki.ros.org/ros_tutorials
arch = i686
arch = x86_64
@@ -15,8 +15,8 @@ pkgbase = ros-noetic-ros-tutorials
depends = ros-noetic-roscpp-tutorials
depends = ros-noetic-rospy-tutorials
depends = ros-noetic-turtlesim
- source = ros-noetic-ros-tutorials-0.9.1.tar.gz::https://github.com/ros/ros_tutorials/archive/0.9.1.tar.gz
- sha256sums = b39929a2ac912326fc114256e755fff5d0f0e5e5e7c99640d013eb7f916b85f4
+ source = ros-noetic-ros-tutorials-1.3.1.tar.gz::https://github.com/ros/ros_tutorials/archive/1.3.1.tar.gz
+ sha256sums = b1071896e92a7060c14e7a1ed71bb4c7613049f4021992b50002574ba70b3d0f
pkgname = ros-noetic-ros-tutorials
diff --git a/PKGBUILD b/PKGBUILD
index a02bfe30c448..6a1999d5768d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,55 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - ros_tutorials contains packages that demonstrate various features of ROS, as well as support packages which help demonstrate those features."
url='https://wiki.ros.org/ros_tutorials'
pkgname='ros-noetic-ros-tutorials'
-pkgver='0.9.1'
+pkgver='1.3.1'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
-pkgrel=3
+pkgrel=1
license=('BSD')
ros_makedepends=(
- ros-noetic-catkin
+ ros-noetic-catkin
)
makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
+ cmake
+ ros-build-tools
+ ${ros_makedepends[@]}
)
ros_depends=(
- ros-noetic-roscpp-tutorials
- ros-noetic-rospy-tutorials
- ros-noetic-turtlesim
+ ros-noetic-roscpp-tutorials
+ ros-noetic-rospy-tutorials
+ ros-noetic-turtlesim
)
depends=(
- ${ros_depends[@]}
+ ${ros_depends[@]}
)
_dir="ros_tutorials-${pkgver}/ros_tutorials"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/ros_tutorials/archive/${pkgver}.tar.gz")
-sha256sums=('b39929a2ac912326fc114256e755fff5d0f0e5e5e7c99640d013eb7f916b85f4')
+sha256sums=('b1071896e92a7060c14e7a1ed71bb4c7613049f4021992b50002574ba70b3d0f')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
-
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
- -DPYTHON_EXECUTABLE=/usr/bin/python \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}