summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGPereira2018-02-22 11:35:01 +0000
committerGPereira2018-02-22 11:35:01 +0000
commit2c14856ea992dd2d9c674670cf52e0882ff6dab8 (patch)
tree533a048e00a099de900cb05aae700e04c87ed097
downloadaur-2c14856ea992dd2d9c674670cf52e0882ff6dab8.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD62
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0621e2cd8f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Feb 22 11:35:01 UTC 2018
+pkgbase = ros-melodic-rosbuild
+ pkgdesc = ROS - rosbuild contains scripts for managing the CMake-based build system for ROS.
+ pkgver = 1.14.3
+ pkgrel = 1
+ url = http://ros.org/wiki/rosbuild
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ makedepends = pkg-config
+ depends = ros-melodic-message-runtime
+ depends = ros-melodic-message-generation
+ depends = ros-melodic-catkin
+ source = ros-melodic-rosbuild-1.14.3-0.tar.gz::https://github.com/ros-gbp/ros-release/archive/release/melodic/rosbuild/1.14.3-0.tar.gz
+ sha256sums = 2572ffaa018d04a7f8782d778c1483e65223952e13654b90e578ad52bbbebcb1
+
+pkgname = ros-melodic-rosbuild
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..781332ad5e24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - rosbuild contains scripts for managing the CMake-based build system for ROS."
+url='http://ros.org/wiki/rosbuild'
+
+pkgname='ros-melodic-rosbuild'
+pkgver='1.14.3'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ pkg-config)
+
+ros_depends=(ros-melodic-message-runtime
+ ros-melodic-message-generation
+ ros-melodic-catkin)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/rosbuild/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros-release-release-melodic-rosbuild-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros-release/archive/release/melodic/rosbuild/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('2572ffaa018d04a7f8782d778c1483e65223952e13654b90e578ad52bbbebcb1')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}