summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGPereira2018-02-24 12:19:12 +0000
committerGPereira2018-02-24 12:19:12 +0000
commitd13cea7393435672304ad9ceec3787b7e8290fea (patch)
tree86a7fa9e0e1af7c2a78a5cdc2c2afbbe47327423
downloadaur-d13cea7393435672304ad9ceec3787b7e8290fea.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD60
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8723f1f24931
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ros-melodic-rosclean
+ pkgdesc = ROS - rosclean: cleanup filesystem resources (e.g.
+ pkgver = 1.14.3
+ pkgrel = 1
+ url = http://ros.org/wiki/rosclean
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ depends = python2-rospkg
+ source = ros-melodic-rosclean-1.14.3-0.tar.gz::https://github.com/ros-gbp/ros-release/archive/release/melodic/rosclean/1.14.3-0.tar.gz
+ sha256sums = c482c749c78680553eb79fb8a9e785d593c0bf4c1b0b35381f6b4319a430ad4b
+
+pkgname = ros-melodic-rosclean
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f24b2f668f00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - rosclean: cleanup filesystem resources (e.g."
+url='http://ros.org/wiki/rosclean'
+
+pkgname='ros-melodic-rosclean'
+pkgver='1.14.3'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ python2-rospkg)
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/rosclean/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros-release-release-melodic-rosclean-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros-release/archive/release/melodic/rosclean/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('c482c749c78680553eb79fb8a9e785d593c0bf4c1b0b35381f6b4319a430ad4b')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}