summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-08 14:03:49 +0100
committerGonçalo Camelo Neves Pereira2018-05-08 14:03:49 +0100
commita83183201b800f92c23e88d8d7bb4302f9fe85b9 (patch)
treef193e5b4123d1ba16282c5d9aacfea2511586ba7
downloadaur-a83183201b800f92c23e88d8d7bb4302f9fe85b9.tar.gz
Initial Commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD64
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21ea93ff4099
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ros-melodic-roscpp-serialization
+ pkgdesc = ROS - roscpp_serialization contains the code for serialization as described in MessagesSerializationAndAdaptingTypes.
+ pkgver = 0.6.10
+ pkgrel = 1
+ url = http://ros.org/wiki/roscpp_serialization
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-roscpp-traits
+ makedepends = ros-melodic-cpp-common
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-rostime
+ depends = ros-melodic-roscpp-traits
+ depends = ros-melodic-cpp-common
+ depends = ros-melodic-rostime
+ source = ros-melodic-roscpp-serialization-0.6.10-0.tar.gz::https://github.com/ros-gbp/roscpp_core-release/archive/release/melodic/roscpp_serialization/0.6.10-0.tar.gz
+ sha256sums = f74464ebf956d0d6cb60770875781900d84e3ff7eb56fdf8be0402ce4f5fe6ee
+
+pkgname = ros-melodic-roscpp-serialization
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b79cbb7fbb25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - roscpp_serialization contains the code for serialization as described in MessagesSerializationAndAdaptingTypes."
+url='http://ros.org/wiki/roscpp_serialization'
+
+pkgname='ros-melodic-roscpp-serialization'
+pkgver='0.6.10'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-roscpp-traits
+ ros-melodic-cpp-common
+ ros-melodic-catkin
+ ros-melodic-rostime)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-roscpp-traits
+ ros-melodic-cpp-common
+ ros-melodic-rostime)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/roscpp_serialization/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/roscpp_core-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="roscpp_core-release-release-melodic-roscpp_serialization-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/roscpp_core-release/archive/release/melodic/roscpp_serialization/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('f74464ebf956d0d6cb60770875781900d84e3ff7eb56fdf8be0402ce4f5fe6ee')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}