summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHermann von Kleist2020-05-10 00:43:38 +0200
committerHermann von Kleist2020-05-10 00:43:38 +0200
commitdf991e15f7478632b111ccece90d2b3a47742b18 (patch)
tree0d35548a6334321505c8e59a9bf74bd866761960
parent321e579d9cbdcc0701684511748c4993a861a8d8 (diff)
downloadaur-df991e15f7478632b111ccece90d2b3a47742b18.tar.gz
Update to 1.15.4 and noetic.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--python38.patch17
3 files changed, 15 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6f36179c052..46967ae5f981 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
-pkgbase = ros-melodic-rosgraph
+pkgbase = ros-noetic-rosgraph
pkgdesc = ROS - rosgraph contains the rosgraph command-line tool, which prints information about the ROS Computation Graph.
- pkgver = 1.14.3
- pkgrel = 2
+ pkgver = 1.15.4
+ pkgrel = 1
url = https://wiki.ros.org/rosgraph
arch = any
license = BSD
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-melodic-catkin
+ makedepends = ros-noetic-catkin
depends = python-yaml
depends = python-netifaces
depends = python-rospkg
- source = ros-melodic-rosgraph-1.14.3.tar.gz::https://github.com/ros/ros_comm/archive/1.14.3.tar.gz
- source = python38.patch
- sha256sums = 3e49bef96b8a0f9684e5c4f1736d171e9c8842a3979d5d3c6442b53698e8167f
- sha256sums = 57d5c7ad1638ba2bd4056a0be8ce15e681a77984b54c04a84799ef51c37e46c2
+ source = ros-noetic-rosgraph-1.15.4.tar.gz::https://github.com/ros/ros_comm/archive/1.15.4.tar.gz
+ sha256sums = d5c96a81e0c8554b77666bca5dcc68e03083a761a117038ff9b65f9643751c9e
-pkgname = ros-melodic-rosgraph
+pkgname = ros-noetic-rosgraph
diff --git a/PKGBUILD b/PKGBUILD
index d35b06487a37..b63e208b3aa4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgdesc="ROS - rosgraph contains the rosgraph command-line tool, which prints information about the ROS Computation Graph."
url='https://wiki.ros.org/rosgraph'
-pkgname='ros-melodic-rosgraph'
-pkgver='1.14.3'
+pkgname='ros-noetic-rosgraph'
+pkgver='1.15.4'
arch=('any')
-pkgrel=2
+pkgrel=1
license=('BSD')
ros_makedepends=(
- ros-melodic-catkin
+ ros-noetic-catkin
)
makedepends=(
@@ -30,38 +30,29 @@ depends=(
)
_dir="ros_comm-${pkgver}/tools/rosgraph"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/ros_comm/archive/${pkgver}.tar.gz"
- "python38.patch")
-sha256sums=('3e49bef96b8a0f9684e5c4f1736d171e9c8842a3979d5d3c6442b53698e8167f'
- '57d5c7ad1638ba2bd4056a0be8ce15e681a77984b54c04a84799ef51c37e46c2')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/ros_comm/archive/${pkgver}.tar.gz")
+sha256sums=('d5c96a81e0c8554b77666bca5dcc68e03083a761a117038ff9b65f9643751c9e')
prepare() {
cd "${srcdir}/${_dir}"
- patch -uN src/rosgraph/roslogging.py ../../../python38.patch || return 1
}
build() {
# Use ROS environment variables.
source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
# Create the build directory.
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
# Build the project.
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}
diff --git a/python38.patch b/python38.patch
deleted file mode 100644
index 932af17380f2..000000000000
--- a/python38.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/tools/rosgraph/src/rosgraph/roslogging.py
-+++ b/tools/rosgraph/src/rosgraph/roslogging.py
-@@ -49,12 +49,12 @@ from rospkg.environment import ROS_LOG_DIR
- class LoggingException(Exception): pass
-
- class RospyLogger(logging.getLoggerClass()):
-- def findCaller(self, dummy=False): # Dummy second arg to match Python3 function declaration
-+ def findCaller(self, *args, **kwargs):
- """
- Find the stack frame of the caller so that we can note the source
- file name, line number, and function name with class name if possible.
- """
-- file_name, lineno, func_name = super(RospyLogger, self).findCaller()[:3]
-+ file_name, lineno, func_name = super(RospyLogger, self).findCaller(*args, **kwargs)[:3]
-
- f = inspect.currentframe()
- if f is not None: