summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:32:58 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:32:58 +0200
commitdd7de2f78ffe028e8bd092d2e957f816c0cb7b4d (patch)
tree78b02d6998fa46d7a8a8b8df6f4d5ebc4b67193e
parent68611342dd74083926068784effd9ae24a4baa96 (diff)
downloadaur-dd7de2f78ffe028e8bd092d2e957f816c0cb7b4d.tar.gz
Update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD103
2 files changed, 48 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af834284016a..6aba25b7821c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,13 +8,13 @@ pkgbase = ros-melodic-roslisp
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
- depends = ros-melodic-rosgraph-msgs
depends = ros-melodic-std-srvs
- depends = ros-melodic-roslang
+ depends = ros-melodic-rosgraph-msgs
depends = ros-melodic-rospack
+ depends = ros-melodic-roslang
depends = sbcl
- source = ros-melodic-roslisp::git+https://github.com/ros-gbp/roslisp-release.git
- sha256sums = SKIP
+ source = ros-melodic-roslisp-1.9.21-0.tar.gz::https://github.com/ros-gbp/roslisp-release/archive/release/melodic/roslisp/1.9.21-0.tar.gz
+ sha256sums = f75e7abb1e744d5a6703b25356722dbe413f4d8626805aedf61a80ef95036da7
pkgname = ros-melodic-roslisp
diff --git a/PKGBUILD b/PKGBUILD
index cc7205c0f71b..bf8d4721c06f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - Lisp client library for ROS, the Robot Operating System."
url='http://ros.org/wiki/roslisp'
@@ -10,69 +10,54 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-catkin
-)
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
-)
+ros_depends=(ros-melodic-std-srvs
+ ros-melodic-rosgraph-msgs
+ ros-melodic-rospack
+ ros-melodic-roslang)
+depends=(${ros_depends[@]}
+ sbcl)
-ros_depends=(
- ros-melodic-rosgraph-msgs
- ros-melodic-std-srvs
- ros-melodic-roslang
- ros-melodic-rospack
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/roslisp/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/roslisp-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
- sbcl
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/roslisp-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="roslisp-release-release-melodic-roslisp-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/roslisp-release/archive/release/melodic/roslisp/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('f75e7abb1e744d5a6703b25356722dbe413f4d8626805aedf61a80ef95036da7')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}