summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2019-01-09 19:19:26 +0100
committerGonçalo Camelo Neves Pereira2019-01-09 19:19:26 +0100
commit8e73a4d82b78cc9a56be06e3d4b3f08c1d5af8e7 (patch)
tree98effad174d00df6bbcdf500eab09ac492d7bb3d
parent19ba162e2b08c57d994078a1226d648b0702a80b (diff)
downloadaur-8e73a4d82b78cc9a56be06e3d4b3f08c1d5af8e7.tar.gz
New Version
-rw-r--r--PKGBUILD80
1 files changed, 42 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17d5daaeada0..5857b7b4f0cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - rosmake is a ros dependency aware build tool which can be used to build all dependencies in the correct order."
url='http://ros.org/wiki/rosmake'
@@ -10,51 +10,55 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-catkin)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-catkin
+)
-ros_depends=(ros-melodic-catkin)
-depends=(${ros_depends[@]}
- python-rospkg)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/rosmake/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/ros-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-catkin
+)
+
+depends=(
+ ${ros_depends[@]}
+ python-rospkg
+)
-# Tarball version (faster download)
_dir="ros-release-release-melodic-rosmake-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros-release/archive/release/melodic/rosmake/${pkgver}-${_pkgver_patch}.tar.gz")
sha256sums=('eae91dbf54d8a8b4d5e6b34880d6a6c49f77584a3be8dbca37762bb5b9186fca')
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}