summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-08 14:58:48 +0200
committerGonçalo Camelo Neves Pereira2018-09-08 14:58:48 +0200
commitc8cb38f2e26efb878cbd7239bcb2595b75466218 (patch)
tree312a9e27b4801a72ff873ed86425e29f7474681d
parent26b7c1ec806d0f63ff1990131a0dbf058a2a6262 (diff)
downloadaur-c8cb38f2e26efb878cbd7239bcb2595b75466218.tar.gz
Update!
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD97
2 files changed, 59 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7158bdb33034..37ef4689d3ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,9 +9,9 @@ pkgbase = ros-melodic-rosmake
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
depends = ros-melodic-catkin
- depends = python2-rospkg
- source = ros-melodic-rosmake-1.14.4-0.tar.gz::https://github.com/ros-gbp/ros-release/archive/release/melodic/rosmake/1.14.4-0.tar.gz
- sha256sums = eae91dbf54d8a8b4d5e6b34880d6a6c49f77584a3be8dbca37762bb5b9186fca
+ depends = python-rospkg
+ source = ros-melodic-rosmake::git+https://github.com/ros-gbp/ros-release.git
+ sha256sums = SKIP
pkgname = ros-melodic-rosmake
diff --git a/PKGBUILD b/PKGBUILD
index 1eaeea307ddc..d7f346774fe5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - rosmake is a ros dependency aware build tool which can be used to build all dependencies in the correct order."
url='http://ros.org/wiki/rosmake'
@@ -10,51 +10,66 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-catkin)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-catkin
+)
-ros_depends=(ros-melodic-catkin)
-depends=(${ros_depends[@]}
- python2-rospkg)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/rosmake/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/ros-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-catkin
+)
-# Tarball version (faster download)
-_dir="ros-release-release-melodic-rosmake-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros-release/archive/release/melodic/rosmake/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('eae91dbf54d8a8b4d5e6b34880d6a6c49f77584a3be8dbca37762bb5b9186fca')
+depends=(
+ ${ros_depends[@]}
+ python-rospkg
+)
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-gbp/ros-release.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
-
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}