summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-08 14:58:52 +0200
committerGonçalo Camelo Neves Pereira2018-09-08 14:58:52 +0200
commitf2787085fb0978aab003e4e14876231b4200ea4a (patch)
tree4b0bd3769a5fc219080af9f4983e4a499f9a86ea
parent8ec2c378d318dfea3e32611779c3fbee2a04167c (diff)
downloadaur-f2787085fb0978aab003e4e14876231b4200ea4a.tar.gz
Update!
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD99
2 files changed, 61 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b3e67ee66a6..6b5c142abd95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ros-melodic-rosmaster
pkgdesc = ROS - ROS Master implementation.
- pkgver = 1.14.2
+ pkgver = 1.14.3
pkgrel = 1
url = http://ros.org/wiki/rosmaster
arch = any
@@ -9,9 +9,9 @@ pkgbase = ros-melodic-rosmaster
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
depends = ros-melodic-rosgraph
- depends = python2-defusedxml
- source = ros-melodic-rosmaster-1.14.2-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/rosmaster/1.14.2-0.tar.gz
- sha256sums = c9f77088cdb60d9f70456b39bdd8366e85cab6659e2e6c792d4159c5adda52e9
+ depends = python-defusedxml
+ source = ros-melodic-rosmaster::git+https://github.com/ros-gbp/ros_comm-release.git
+ sha256sums = SKIP
pkgname = ros-melodic-rosmaster
diff --git a/PKGBUILD b/PKGBUILD
index 9111961d412e..bb1c024c246d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,75 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - ROS Master implementation."
url='http://ros.org/wiki/rosmaster'
pkgname='ros-melodic-rosmaster'
-pkgver='1.14.2'
+pkgver='1.14.3'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-catkin)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-catkin
+)
-ros_depends=(ros-melodic-rosgraph)
-depends=(${ros_depends[@]}
- python2-defusedxml)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/rosmaster/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-rosgraph
+)
-# Tarball version (faster download)
-_dir="ros_comm-release-release-melodic-rosmaster-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/rosmaster/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('c9f77088cdb60d9f70456b39bdd8366e85cab6659e2e6c792d4159c5adda52e9')
+depends=(
+ ${ros_depends[@]}
+ python-defusedxml
+)
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
-
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}