summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-07-30 00:21:13 -0400
committeracxz2020-07-30 00:21:13 -0400
commit537a3d302eea992386bc7f74360448ceab172895 (patch)
treeb5284f33876419f623a7e0633ea5619765ea389a
parent33e5b331878d7438bd5b75c7025838d7d12d7372 (diff)
downloadaur-537a3d302eea992386bc7f74360448ceab172895.tar.gz
updpkg 1.15.8
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD68
2 files changed, 36 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2c44efd3776..9b5f0e0545ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ros-noetic-rospy
pkgdesc = ROS - rospy is a pure Python client library for ROS.
- pkgver = 1.15.4
+ pkgver = 1.15.8
pkgrel = 1
url = https://wiki.ros.org/rospy
arch = i686
@@ -21,8 +21,8 @@ pkgbase = ros-noetic-rospy
depends = python-yaml
depends = python-rospkg
depends = python-numpy
- source = ros-noetic-rospy-1.15.4.tar.gz::https://github.com/ros/ros_comm/archive/1.15.4.tar.gz
- sha256sums = d5c96a81e0c8554b77666bca5dcc68e03083a761a117038ff9b65f9643751c9e
+ source = ros-noetic-rospy-1.15.8.tar.gz::https://github.com/ros/ros_comm/archive/1.15.8.tar.gz
+ sha256sums = 7a72219b236aef5f0327c3ce6eba6008980a24a986a5b970b17125890887b494
pkgname = ros-noetic-rospy
diff --git a/PKGBUILD b/PKGBUILD
index c5da50db9e58..d4b296db5cfc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,63 +1,61 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - rospy is a pure Python client library for ROS."
url='https://wiki.ros.org/rospy'
pkgname='ros-noetic-rospy'
-pkgver='1.15.4'
+pkgver='1.15.8'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
pkgrel=1
license=('BSD')
ros_makedepends=(
- ros-noetic-catkin
+ ros-noetic-catkin
)
makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
+ cmake
+ ros-build-tools
+ ${ros_makedepends[@]}
)
ros_depends=(
- ros-noetic-genpy
- ros-noetic-rosgraph-msgs
- ros-noetic-std-msgs
- ros-noetic-roscpp
- ros-noetic-rosgraph
- ros-noetic-roslib
+ ros-noetic-genpy
+ ros-noetic-rosgraph-msgs
+ ros-noetic-std-msgs
+ ros-noetic-roscpp
+ ros-noetic-rosgraph
+ ros-noetic-roslib
)
depends=(
- ${ros_depends[@]}
- python-yaml
- python-rospkg
- python-numpy
+ ${ros_depends[@]}
+ python-yaml
+ python-rospkg
+ python-numpy
)
_dir="ros_comm-${pkgver}/clients/rospy"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/ros_comm/archive/${pkgver}.tar.gz")
-sha256sums=('d5c96a81e0c8554b77666bca5dcc68e03083a761a117038ff9b65f9643751c9e')
+sha256sums=('7a72219b236aef5f0327c3ce6eba6008980a24a986a5b970b17125890887b494')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
-
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
- -DPYTHON_EXECUTABLE=/usr/bin/python \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}