summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHermann von Kleist2020-03-19 03:58:26 +0100
committerGitHub2020-03-18 22:58:26 -0400
commit87eb562838b8f1880020b6466c0a3e439c41b810 (patch)
treeaee009fa3212207b777b4a90a5acecec525f03a7
parentaae46b609632bd0b3877dbba37f516ba3f020ad1 (diff)
downloadaur-87eb562838b8f1880020b6466c0a3e439c41b810.tar.gz
Apply patches for current boost version (#2)
* Apply patches for current boost version * Removed io-service.patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--io-service.patch24
3 files changed, 8 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b95bb4599f68..3fea6fe39dd8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-rosserial-server
pkgdesc = ROS - A more performance- and stability-oriented server alternative implemented in C++ to rosserial_python.
pkgver = 0.8.0
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.ros.org/rosserial_server
arch = i686
arch = x86_64
@@ -22,9 +22,9 @@ pkgbase = ros-melodic-rosserial-server
depends = ros-melodic-roscpp
depends = ros-melodic-topic-tools
source = ros-melodic-rosserial-server-0.8.0.tar.gz::https://github.com/ros-drivers/rosserial/archive/0.8.0.tar.gz
- source = io-service.patch
+ source = fix-boost-1-71.patch::https://patch-diff.githubusercontent.com/raw/ros-drivers/rosserial/pull/468.patch
sha256sums = e96cdeb81e1c03fb1c5ad85a740cb0a1a0836c52a24c6a5d97c975084b49d576
- sha256sums = 3020b8961dd3cbe295fdac0b86a43d4da6b8d76b07337d46ba54d12cee4e1cb0
+ sha256sums = 750137d86f3d535be30ecdc904e12355c71a7873a780fc686f6e6f133cd2172a
pkgname = ros-melodic-rosserial-server
diff --git a/PKGBUILD b/PKGBUILD
index 3f2a756817dc..d5b74e22b5ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ url='https://wiki.ros.org/rosserial_server'
pkgname='ros-melodic-rosserial-server'
pkgver='0.8.0'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(
@@ -36,13 +36,13 @@ depends=(
_dir="rosserial-${pkgver}/rosserial_server"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-drivers/rosserial/archive/${pkgver}.tar.gz"
- "io-service.patch")
+ "fix-boost-1-71.patch"::"https://patch-diff.githubusercontent.com/raw/ros-drivers/rosserial/pull/468.patch")
sha256sums=('e96cdeb81e1c03fb1c5ad85a740cb0a1a0836c52a24c6a5d97c975084b49d576'
- '3020b8961dd3cbe295fdac0b86a43d4da6b8d76b07337d46ba54d12cee4e1cb0')
+ '750137d86f3d535be30ecdc904e12355c71a7873a780fc686f6e6f133cd2172a')
prepare() {
- cd "${srcdir}/${_dir}/include/rosserial_server"
- patch -uN async_read_buffer.h ../../../../../io-service.patch || return 1
+ cd "${srcdir}/${_dir}/.."
+ patch -p1 < ${srcdir}/fix-boost-1-71.patch
}
build() {
diff --git a/io-service.patch b/io-service.patch
deleted file mode 100644
index 2ba97de129e8..000000000000
--- a/io-service.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- async_read_buffer.h.orig 2019-11-28 22:48:02.933056047 -0500
-+++ async_read_buffer.h 2019-11-28 22:52:40.829715275 -0500
-@@ -38,6 +38,12 @@
- #include <boost/asio.hpp>
- #include <boost/function.hpp>
-
-+#if BOOST_VERSION >= 107000
-+#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
-+#else
-+#define GET_IO_SERVICE(s) ((s).get_io_service())
-+#endif
-+
- #include <ros/ros.h>
-
- namespace rosserial_server
-@@ -166,7 +172,7 @@
-
- // Post the callback rather than executing it here so, so that we have a chance to do the cleanup
- // below prior to it actually getting run, in the event that the callback queues up another read.
-- stream_.get_io_service().post(boost::bind(read_success_callback_, stream));
-+ GET_IO_SERVICE(stream_).post(boost::bind(read_success_callback_, stream));
-
- // Resetting these values clears our state so that we know there isn't a callback pending.
- read_requested_bytes_ = 0;