summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHermann von Kleist2020-05-10 01:23:45 +0200
committerHermann von Kleist2020-05-10 01:23:45 +0200
commitf621c2b8380285e71bcdd81c842cf74c04c74cbf (patch)
tree246f92c4f2eb0bb65ecf73e7ebf2b79707f4ada0
parent9c8dad62da78e58df74226a5b46003a57a661462 (diff)
downloadaur-f621c2b8380285e71bcdd81c842cf74c04c74cbf.tar.gz
Update to 0.7.1 and noetic
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5b5d8029b91..c748d5d40697 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = ros-melodic-rostime
+pkgbase = ros-noetic-rostime
pkgdesc = ROS - Time and Duration implementations for C++ libraries, including roscpp.
- pkgver = 0.6.13
+ pkgver = 0.7.1
pkgrel = 2
url = https://wiki.ros.org/rostime
arch = i686
@@ -11,13 +11,13 @@ pkgbase = ros-melodic-rostime
license = BSD
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-melodic-cpp-common
- makedepends = ros-melodic-catkin
+ makedepends = ros-noetic-cpp-common
+ makedepends = ros-noetic-catkin
makedepends = boost
- depends = ros-melodic-cpp-common
+ depends = ros-noetic-cpp-common
depends = boost
- source = ros-melodic-rostime-0.6.13.tar.gz::https://github.com/ros/roscpp_core/archive/0.6.13.tar.gz
- sha256sums = 6740da6424373c8ffb075b30272f7a46804a76015649bc4f54fd1963d50a1e49
+ source = ros-noetic-rostime-0.7.1.tar.gz::https://github.com/ros/roscpp_core/archive/0.7.1.tar.gz
+ sha256sums = 8fddbafd3fc76470e4a706f7923b7a03f914943d7edb0b70273d8b98e003b108
-pkgname = ros-melodic-rostime
+pkgname = ros-noetic-rostime
diff --git a/PKGBUILD b/PKGBUILD
index 85d882eda927..7d769a80af71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
pkgdesc="ROS - Time and Duration implementations for C++ libraries, including roscpp."
url='https://wiki.ros.org/rostime'
-pkgname='ros-melodic-rostime'
-pkgver='0.6.13'
+pkgname='ros-noetic-rostime'
+pkgver='0.7.1'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
pkgrel=2
license=('BSD')
ros_makedepends=(
- ros-melodic-cpp-common
- ros-melodic-catkin
+ ros-noetic-cpp-common
+ ros-noetic-catkin
)
makedepends=(
@@ -22,7 +22,7 @@ makedepends=(
)
ros_depends=(
- ros-melodic-cpp-common
+ ros-noetic-cpp-common
)
depends=(
@@ -32,25 +32,22 @@ depends=(
_dir="roscpp_core-${pkgver}/rostime"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/roscpp_core/archive/${pkgver}.tar.gz")
-sha256sums=('6740da6424373c8ffb075b30272f7a46804a76015649bc4f54fd1963d50a1e49')
+sha256sums=('8fddbafd3fc76470e4a706f7923b7a03f914943d7edb0b70273d8b98e003b108')
build() {
# Use ROS environment variables.
source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
# Create the build directory.
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
# Build the project.
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make