summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-13 19:49:40 +0100
committerGonçalo Camelo Neves Pereira2018-05-13 19:49:40 +0100
commit9b2bf4826e7632578c324deb3e78a5c7359eeea2 (patch)
tree6ebffb5fc5467c933e742f099d765535073ef3bb
downloadaur-9b2bf4826e7632578c324deb3e78a5c7359eeea2.tar.gz
Update
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD66
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1759f1b96727
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ros-melodic-rqt-publisher
+ pkgdesc = ROS - rqt_publisher provides a GUI plugin for publishing arbitrary messages with fixed or computed field values.
+ pkgver = 0.4.8
+ pkgrel = 1
+ url = http://wiki.ros.org/rqt_publisher
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-qt-gui-py-common
+ depends = ros-melodic-rosmsg
+ depends = ros-melodic-roslib
+ depends = ros-melodic-rqt-py-common
+ depends = ros-melodic-rqt-gui-py
+ depends = ros-melodic-rqt-gui
+ depends = ros-melodic-python-qt-binding
+ depends = python2-rospkg
+ source = ros-melodic-rqt-publisher-0.4.8-0.tar.gz::https://github.com/ros-gbp/rqt_publisher-release/archive/release/melodic/rqt_publisher/0.4.8-0.tar.gz
+ sha256sums = 9411fa1eb8fefee5ab7653c83dc2baa44cf352797759436fdfaa48de29e098e3
+
+pkgname = ros-melodic-rqt-publisher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3e9f7b7b618
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - rqt_publisher provides a GUI plugin for publishing arbitrary messages with fixed or computed field values."
+url='http://wiki.ros.org/rqt_publisher'
+
+pkgname='ros-melodic-rqt-publisher'
+pkgver='0.4.8'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-qt-gui-py-common
+ ros-melodic-rosmsg
+ ros-melodic-roslib
+ ros-melodic-rqt-py-common
+ ros-melodic-rqt-gui-py
+ ros-melodic-rqt-gui
+ ros-melodic-python-qt-binding)
+depends=(${ros_depends[@]}
+ python2-rospkg)
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/rqt_publisher/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_publisher-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rqt_publisher-release-release-melodic-rqt_publisher-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt_publisher-release/archive/release/melodic/rqt_publisher/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('9411fa1eb8fefee5ab7653c83dc2baa44cf352797759436fdfaa48de29e098e3')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}