summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:37:00 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:37:00 +0200
commit3e52fa6da2d86bb94ab6c0731829a0cc501d7737 (patch)
tree3fb56af555cb43b57acfed4393428cdad5594f6b
parentee3f90b1f254c6384af375c719ad6eb8ab21e304 (diff)
downloadaur-3e52fa6da2d86bb94ab6c0731829a0cc501d7737.tar.gz
Update
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD109
2 files changed, 55 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb5271757e4c..f0c93429c452 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,19 +8,19 @@ pkgbase = ros-melodic-rqt-tf-tree
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
- depends = ros-melodic-rqt-gui
+ depends = ros-melodic-rqt-graph
+ depends = ros-melodic-qt-dotgraph
+ depends = ros-melodic-tf2-msgs
+ depends = ros-melodic-geometry-msgs
depends = ros-melodic-rqt-gui-py
+ depends = ros-melodic-rqt-gui
depends = ros-melodic-tf2-ros
+ depends = ros-melodic-tf2
depends = ros-melodic-python-qt-binding
- depends = ros-melodic-geometry-msgs
depends = ros-melodic-rospy
- depends = ros-melodic-rqt-graph
- depends = ros-melodic-qt-dotgraph
- depends = ros-melodic-tf2
- depends = ros-melodic-tf2-msgs
depends = python-rospkg
- source = ros-melodic-rqt-tf-tree::git+https://github.com/ros-gbp/rqt_tf_tree-release.git
- sha256sums = SKIP
+ source = ros-melodic-rqt-tf-tree-0.5.8-0.tar.gz::https://github.com/ros-gbp/rqt_tf_tree-release/archive/release/melodic/rqt_tf_tree/0.5.8-0.tar.gz
+ sha256sums = 9513090b80a462fde8cff0e4ba44ceb1c2db175720100c22502e03bbccd3f962
pkgname = ros-melodic-rqt-tf-tree
diff --git a/PKGBUILD b/PKGBUILD
index 7f044d631671..de8c82a08c04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - rqt_tf_tree provides a GUI plugin for visualizing the ROS TF frame tree."
url='http://wiki.ros.org/rqt_tf_tree'
@@ -10,75 +10,60 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-catkin
-)
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
-)
+ros_depends=(ros-melodic-rqt-graph
+ ros-melodic-qt-dotgraph
+ ros-melodic-tf2-msgs
+ ros-melodic-geometry-msgs
+ ros-melodic-rqt-gui-py
+ ros-melodic-rqt-gui
+ ros-melodic-tf2-ros
+ ros-melodic-tf2
+ ros-melodic-python-qt-binding
+ ros-melodic-rospy)
+depends=(${ros_depends[@]}
+ python-rospkg)
-ros_depends=(
- ros-melodic-rqt-gui
- ros-melodic-rqt-gui-py
- ros-melodic-tf2-ros
- ros-melodic-python-qt-binding
- ros-melodic-geometry-msgs
- ros-melodic-rospy
- ros-melodic-rqt-graph
- ros-melodic-qt-dotgraph
- ros-melodic-tf2
- ros-melodic-tf2-msgs
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/rqt_tf_tree/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_tf_tree-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
- python-rospkg
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_tf_tree-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="rqt_tf_tree-release-release-melodic-rqt_tf_tree-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt_tf_tree-release/archive/release/melodic/rqt_tf_tree/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('9513090b80a462fde8cff0e4ba44ceb1c2db175720100c22502e03bbccd3f962')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}