summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchmad Fathoni2021-04-29 17:19:41 +0700
committerAchmad Fathoni2021-04-29 17:19:41 +0700
commitade2430969fc214a3a9014fca6f79d3d8a746230 (patch)
treece8ec0996f2450da332ad0660f40ed11e0eb3957
parent850cdb6c90aba12b3b5ac9de36395024bf2431a8 (diff)
downloadaur-ade2430969fc214a3a9014fca6f79d3d8a746230.tar.gz
Add patch
-rw-r--r--PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd165e4a46d3..0541abe27ce6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,8 +39,18 @@ depends=(
)
_dir="rqt_tf_tree-${pkgver}"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/rqt_tf_tree/archive/${pkgver}.tar.gz")
-sha256sums=('0d5996679310b747ac49d52c39e7869870458065b8ba118ed48b105d9f252604')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/rqt_tf_tree/archive/${pkgver}.tar.gz"
+ "https://github.com/ros-visualization/rqt_tf_tree/pull/28.patch"
+ "https://github.com/ros-visualization/rqt_tf_tree/pull/30.patch")
+sha256sums=('0d5996679310b747ac49d52c39e7869870458065b8ba118ed48b105d9f252604'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "$srcdir/$_dir"
+ patch --forward --strip=1 --input="${srcdir}/28.patch"
+ patch --forward --strip=1 --input="${srcdir}/30.patch"
+}
build() {
# Use ROS environment variables.