summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormajor2020-01-10 01:30:07 +0000
committermajor2020-01-10 01:30:07 +0000
commit580a253992ab9e7af6ba638fb178a73d3ece82aa (patch)
treef46756649ea8f91a5b71de5220c0de032ee6371f
downloadaur-580a253992ab9e7af6ba638fb178a73d3ece82aa.tar.gz
initial commit with adjusted kinetic package (changes python2 to python3, kinetic to melodic)
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD54
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2a4ccfe4ac7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ros-melodic-slam-gmapping
+ pkgdesc = ROS - slam_gmapping contains a wrapper around gmapping which provides SLAM capabilities.
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = http://ros.org/wiki/slam_gmapping
+ arch = any
+ license = CreativeCommons-by-nc-sa-2.0
+ makedepends = cmake
+ makedepends = git
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-gmapping
+ depends = ros-melodic-openslam-gmapping
+ source = slam_gmapping::git+https://github.com/ros-gbp/slam_gmapping-release.git#tag=release/melodic/slam_gmapping/1.4.0-1
+ md5sums = SKIP
+
+pkgname = ros-melodic-slam-gmapping
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2523703f41f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - slam_gmapping contains a wrapper around gmapping which provides SLAM capabilities."
+url='http://ros.org/wiki/slam_gmapping'
+
+pkgname='ros-melodic-slam-gmapping'
+pkgver='1.4.0'
+_pkgver_patch=1
+arch=('any')
+pkgrel=1
+license=('CreativeCommons-by-nc-sa-2.0')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-gmapping
+ ros-melodic-openslam-gmapping)
+depends=(${ros_depends[@]})
+
+_tag=release/melodic/slam_gmapping/${pkgver}-${_pkgver_patch}
+_dir=slam_gmapping
+source=("${_dir}"::"git+https://github.com/ros-gbp/slam_gmapping-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.8 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.8.so \
+ -DPYTHON_BASENAME=-python3.8 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}