summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-12-22 18:21:17 -0500
committeracxz2020-12-22 18:21:17 -0500
commit30447751217c4968fa0320c0fbeecd3ffdaa422f (patch)
tree1653e7a3efc8b4d9d6bff3f84ba7b32a61003571
parent8c8483b0e9268a7d6af4e66e85b64dd2db2bc771 (diff)
downloadaur-30447751217c4968fa0320c0fbeecd3ffdaa422f.tar.gz
use python instead of python2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD83
2 files changed, 40 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12aad874031e..8714133afe09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-noetic-swri-console
pkgdesc = ROS - A rosout GUI viewer developed at Southwest Research Insititute as an alternative to rqt_console.
pkgver = 1.1.0
- pkgrel = 3
+ pkgrel = 4
url = http://ros.org/wiki/swri_console
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 3d91cc5f0db7..b2f4c568d20d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,56 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - A rosout GUI viewer developed at Southwest Research Insititute as an alternative to rqt_console."
url='http://ros.org/wiki/swri_console'
pkgname='ros-noetic-swri-console'
pkgver='1.1.0'
-_pkgver_patch=0
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
-pkgrel=3
+pkgrel=4
license=('BSD')
-ros_makedepends=(ros-noetic-rosgraph-msgs
- ros-noetic-roscpp
- ros-noetic-rosbag-storage
- ros-noetic-catkin)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]}
- boost
- qt5-base)
-
-ros_depends=(ros-noetic-rosgraph-msgs
- ros-noetic-roscpp
- ros-noetic-rosbag-storage)
-depends=(${ros_depends[@]}
- boost
- qt5-base)
-
-# Git version (e.g. for debugging)
-# _tag=release/noetic/swri_console/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/swri-robotics-gbp/swri_console-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
-
-# Tarball version (faster download)
+ros_makedepends=(
+ ros-noetic-rosgraph-msgs
+ ros-noetic-roscpp
+ ros-noetic-rosbag-storage
+ ros-noetic-catkin)
+makedepends=(
+ cmake
+ ros-build-tools
+ ${ros_makedepends[@]}
+ boost
+ qt5-base)
+
+ros_depends=(
+ ros-noetic-rosgraph-msgs
+ ros-noetic-roscpp
+ ros-noetic-rosbag-storage)
+depends=(
+ ${ros_depends[@]}
+ boost
+ qt5-base)
+
_dir="swri_console-${pkgver}"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/swri-robotics/swri_console/archive/${pkgver}.tar.gz")
sha256sums=('da27e4f92247ce7016a4325ef7ffea0ed18fa6fe671ce0b7f17652778ce9481c')
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
-
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}