summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-05-28 00:54:13 -0400
committeracxz2020-05-28 00:54:13 -0400
commit557bb4cdc228a9012e3bfe00a37c02fab623b3cf (patch)
tree534b95b9ac6e4a127ed9fc18ad0b6bc5cb6010fb
parent8dbba8b0a1a334be6e5bc0358e1ed04a2ba30146 (diff)
downloadaur-557bb4cdc228a9012e3bfe00a37c02fab623b3cf.tar.gz
updpkg
-rw-r--r--.SRCINFO18
-rw-r--r--CMakeLists-signal.patch11
-rw-r--r--PKGBUILD19
3 files changed, 16 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6e21930f5c1..db86466a2f13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,13 @@
pkgbase = ros-noetic-tf2
pkgdesc = ROS - tf2 is the second generation of the transform library, which lets the user keep track of multiple coordinate frames over time.
- pkgver = 0.6.5
- pkgrel = 2
- url = https://www.wiki.ros.org/tf2
- arch = any
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = https://wiki.ros.org/tf2
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
license = BSD
makedepends = cmake
makedepends = ros-build-tools
@@ -16,10 +20,8 @@ pkgbase = ros-noetic-tf2
depends = ros-noetic-tf2-msgs
depends = ros-noetic-geometry-msgs
depends = console-bridge
- source = ros-noetic-tf2-0.6.5.tar.gz::https://github.com/ros/geometry2/archive/0.6.5.tar.gz
- source = CMakeLists-signal.patch
- sha256sums = 9a1268621518fc22afd7b12ef1cf30e6901a57b054535924d1d74fd5d267773a
- sha256sums = 878047021778a148cac5a2a6f04e8ee45df593f294022db053d42bc7e5692dbd
+ source = ros-noetic-tf2-0.7.1.tar.gz::https://github.com/ros/geometry2/archive/0.7.1.tar.gz
+ sha256sums = 552aaa6b11cb1ea0bff3f6b3b354a3439b4a27a4289c26957e13b034027bbb0e
pkgname = ros-noetic-tf2
diff --git a/CMakeLists-signal.patch b/CMakeLists-signal.patch
deleted file mode 100644
index b948e26aced1..000000000000
--- a/CMakeLists-signal.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.old 2019-05-24 23:35:56.152546901 -0400
-+++ CMakeLists.txt 2019-05-24 23:36:06.709213096 -0400
-@@ -3,7 +3,7 @@
-
- find_package(console_bridge REQUIRED)
- find_package(catkin REQUIRED COMPONENTS geometry_msgs rostime tf2_msgs)
--find_package(Boost REQUIRED COMPONENTS signals system thread)
-+find_package(Boost REQUIRED COMPONENTS system thread)
-
- catkin_package(
- INCLUDE_DIRS include
diff --git a/PKGBUILD b/PKGBUILD
index 8a78fa7ce881..263d1ff1bddc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Script generated with import_catkin_packages.py.
# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - tf2 is the second generation of the transform library, which lets the user keep track of multiple coordinate frames over time."
-url='https://www.wiki.ros.org/tf2'
+url='https://wiki.ros.org/tf2'
pkgname='ros-noetic-tf2'
-pkgver='0.6.5'
-arch=('any')
-pkgrel=2
+pkgver='0.7.1'
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
+pkgrel=1
license=('BSD')
ros_makedepends=(
@@ -35,15 +35,8 @@ depends=(
)
_dir="geometry2-${pkgver}/tf2"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/geometry2/archive/${pkgver}.tar.gz"
- CMakeLists-signal.patch)
-sha256sums=('9a1268621518fc22afd7b12ef1cf30e6901a57b054535924d1d74fd5d267773a'
- '878047021778a148cac5a2a6f04e8ee45df593f294022db053d42bc7e5692dbd')
-
-prepare() {
- cd "${srcdir}/${_dir}"
- patch -uN CMakeLists.txt "${srcdir}/CMakeLists-signal.patch" || return 1
-}
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/geometry2/archive/${pkgver}.tar.gz")
+sha256sums=('552aaa6b11cb1ea0bff3f6b3b354a3439b4a27a4289c26957e13b034027bbb0e')
build() {
# Use ROS environment variables.