summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-05-24 12:19:46 -0400
committeracxz2020-05-24 12:19:46 -0400
commit8dbba8b0a1a334be6e5bc0358e1ed04a2ba30146 (patch)
tree986dcd00c5d3fa7be8caaadcff6a91122beed7c7
parentf67cf8aa2de376d0cd4a3ed18e4e97407c2a0411 (diff)
downloadaur-8dbba8b0a1a334be6e5bc0358e1ed04a2ba30146.tar.gz
upd to noetic, cmake vars, python
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 21 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00bb0410b882..e6e21930f5c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = ros-melodic-tf2
+pkgbase = ros-noetic-tf2
pkgdesc = ROS - tf2 is the second generation of the transform library, which lets the user keep track of multiple coordinate frames over time.
pkgver = 0.6.5
pkgrel = 2
@@ -7,19 +7,19 @@ pkgbase = ros-melodic-tf2
license = BSD
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-melodic-rostime
- makedepends = ros-melodic-tf2-msgs
- makedepends = ros-melodic-catkin
- makedepends = ros-melodic-geometry-msgs
+ makedepends = ros-noetic-rostime
+ makedepends = ros-noetic-tf2-msgs
+ makedepends = ros-noetic-catkin
+ makedepends = ros-noetic-geometry-msgs
makedepends = console-bridge
- depends = ros-melodic-rostime
- depends = ros-melodic-tf2-msgs
- depends = ros-melodic-geometry-msgs
+ depends = ros-noetic-rostime
+ depends = ros-noetic-tf2-msgs
+ depends = ros-noetic-geometry-msgs
depends = console-bridge
- source = ros-melodic-tf2-0.6.5.tar.gz::https://github.com/ros/geometry2/archive/0.6.5.tar.gz
+ source = ros-noetic-tf2-0.6.5.tar.gz::https://github.com/ros/geometry2/archive/0.6.5.tar.gz
source = CMakeLists-signal.patch
sha256sums = 9a1268621518fc22afd7b12ef1cf30e6901a57b054535924d1d74fd5d267773a
sha256sums = 878047021778a148cac5a2a6f04e8ee45df593f294022db053d42bc7e5692dbd
-pkgname = ros-melodic-tf2
+pkgname = ros-noetic-tf2
diff --git a/PKGBUILD b/PKGBUILD
index 287724095ee4..8a78fa7ce881 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
pkgdesc="ROS - tf2 is the second generation of the transform library, which lets the user keep track of multiple coordinate frames over time."
url='https://www.wiki.ros.org/tf2'
-pkgname='ros-melodic-tf2'
+pkgname='ros-noetic-tf2'
pkgver='0.6.5'
arch=('any')
pkgrel=2
license=('BSD')
ros_makedepends=(
- ros-melodic-rostime
- ros-melodic-tf2-msgs
- ros-melodic-catkin
- ros-melodic-geometry-msgs
+ ros-noetic-rostime
+ ros-noetic-tf2-msgs
+ ros-noetic-catkin
+ ros-noetic-geometry-msgs
)
makedepends=(
@@ -24,9 +24,9 @@ makedepends=(
)
ros_depends=(
- ros-melodic-rostime
- ros-melodic-tf2-msgs
- ros-melodic-geometry-msgs
+ ros-noetic-rostime
+ ros-noetic-tf2-msgs
+ ros-noetic-geometry-msgs
)
depends=(
@@ -48,24 +48,17 @@ prepare() {
build() {
# Use ROS environment variables.
source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
# Create the build directory.
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
# Build the project.
cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}