summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-05-23 08:07:21 -0400
committerFelix Exner2020-07-28 13:26:52 +0200
commita6382b9d896050d7f51fad5b8bdab6ff13ab700a (patch)
tree2695be8652e1a30016191928d0152d18b311cb9a
downloadaur-a6382b9d896050d7f51fad5b8bdab6ff13ab700a.tar.gz
create package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD57
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f707b45c9c4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ros-melodic-trac-ik
+ pkgdesc = ROS - The ROS packages in this repository were created to provide an improved alternative Inverse Kinematics solver to the popular inverse Jacobian methods in KDL.
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = http://wiki.ros.org/trac_ik
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-trac-ik-python
+ depends = ros-melodic-trac-ik-lib
+ depends = ros-melodic-trac-ik-examples
+ depends = ros-melodic-trac-ik-kinematics-plugin
+ source = trac_ik-1.5.1.tar.gz::https://bitbucket.org/traclabs/trac_ik/get/1.5.1.tar.gz
+ sha256sums = 67bdfb8dfcdf99c4ff5bd10de3c214527443a5c1ac54c99a0b5590d2692bf676
+
+pkgname = ros-melodic-trac-ik
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed9babc19fbb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Script generated with create_pkgbuild.py
+# For more information: https://github.com/ros-melodic-arch/ros-build-tools-py3
+pkgdesc="ROS - The ROS packages in this repository were created to provide an improved alternative Inverse Kinematics solver to the popular inverse Jacobian methods in KDL."
+url='http://wiki.ros.org/trac_ik'
+
+pkgname='ros-melodic-trac-ik'
+pkgver='1.5.1'
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=(
+ 'cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
+
+ros_depends=(
+ ros-melodic-trac-ik-python
+ ros-melodic-trac-ik-lib
+ ros-melodic-trac-ik-examples
+ ros-melodic-trac-ik-kinematics-plugin
+)
+
+depends=(${ros_depends[@]})
+
+_dir="traclabs-trac_ik-f4597094e974/trac_ik"
+source=("trac_ik-${pkgver}.tar.gz"::"https://bitbucket.org/traclabs/trac_ik/get/${pkgver}.tar.gz")
+sha256sums=('67bdfb8dfcdf99c4ff5bd10de3c214527443a5c1ac54c99a0b5590d2692bf676')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}
+