summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:40:06 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:40:06 +0200
commitdc398a4add7c988293b03479e19d583d9399914e (patch)
treefd7412c8020c0369da52c8f2a1b40472189f44c3
parentd8e496f525f26ecac77b920a5d7c02441ffb3c23 (diff)
downloadaur-dc398a4add7c988293b03479e19d583d9399914e.tar.gz
Update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD111
2 files changed, 54 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09b3228f848f..f4aa0b918242 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,20 +8,20 @@ pkgbase = ros-melodic-turtle-tf
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-melodic-tf
+ makedepends = ros-melodic-std-msgs
+ makedepends = ros-melodic-roscpp
makedepends = ros-melodic-turtlesim
makedepends = ros-melodic-catkin
makedepends = ros-melodic-geometry-msgs
makedepends = ros-melodic-rospy
- makedepends = ros-melodic-roscpp
- makedepends = ros-melodic-std-msgs
depends = ros-melodic-tf
+ depends = ros-melodic-std-msgs
+ depends = ros-melodic-roscpp
depends = ros-melodic-turtlesim
depends = ros-melodic-geometry-msgs
depends = ros-melodic-rospy
- depends = ros-melodic-roscpp
- depends = ros-melodic-std-msgs
- source = ros-melodic-turtle-tf::git+https://github.com/ros-gbp/geometry_tutorials-release.git
- sha256sums = SKIP
+ source = ros-melodic-turtle-tf-0.2.2-0.tar.gz::https://github.com/ros-gbp/geometry_tutorials-release/archive/release/melodic/turtle_tf/0.2.2-0.tar.gz
+ sha256sums = 182947fcfff5ec44a27e343306a78fd488fbcaff6d8ca894ed0646846293f02d
pkgname = ros-melodic-turtle-tf
diff --git a/PKGBUILD b/PKGBUILD
index 5e9f6ec1441e..ee2d427b4997 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - turtle_tf demonstrates how to write a tf broadcaster and listener with the turtlesim."
url='http://ros.org/wiki/turtle_tf'
@@ -10,76 +10,61 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-tf
- ros-melodic-turtlesim
- ros-melodic-catkin
- ros-melodic-geometry-msgs
- ros-melodic-rospy
- ros-melodic-roscpp
- ros-melodic-std-msgs
-)
+ros_makedepends=(ros-melodic-tf
+ ros-melodic-std-msgs
+ ros-melodic-roscpp
+ ros-melodic-turtlesim
+ ros-melodic-catkin
+ ros-melodic-geometry-msgs
+ ros-melodic-rospy)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
-)
+ros_depends=(ros-melodic-tf
+ ros-melodic-std-msgs
+ ros-melodic-roscpp
+ ros-melodic-turtlesim
+ ros-melodic-geometry-msgs
+ ros-melodic-rospy)
+depends=(${ros_depends[@]})
-ros_depends=(
- ros-melodic-tf
- ros-melodic-turtlesim
- ros-melodic-geometry-msgs
- ros-melodic-rospy
- ros-melodic-roscpp
- ros-melodic-std-msgs
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/turtle_tf/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/geometry_tutorials-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/geometry_tutorials-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="geometry_tutorials-release-release-melodic-turtle_tf-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/geometry_tutorials-release/archive/release/melodic/turtle_tf/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('182947fcfff5ec44a27e343306a78fd488fbcaff6d8ca894ed0646846293f02d')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}