summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-05-24 12:21:20 -0400
committeracxz2020-05-24 12:21:20 -0400
commit77471f54ea27160c66a8d5e73e8c50253e21fd41 (patch)
tree43ed169b8c4dc79f741b840c095908fafc7a42e2
parenta02f182de0c670f428eca7e32da38f1531339c66 (diff)
downloadaur-77471f54ea27160c66a8d5e73e8c50253e21fd41.tar.gz
upd to noetic, cmake vars, python
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD45
2 files changed, 37 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9ae1b083acc..a67d8b1fb5b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = ros-melodic-turtlebot3-example
+pkgbase = ros-noetic-turtlebot3-example
pkgdesc = ROS - This package provides four TurtleBot3 basic example include move using interactive marker, move and stop using LDS, move to goal position, move to custom routes.
pkgver = 1.2.2
pkgrel = 1
@@ -7,23 +7,23 @@ pkgbase = ros-melodic-turtlebot3-example
license = Apache-2.0
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-melodic-catkin
- makedepends = ros-melodic-message-generation
- makedepends = ros-melodic-message-runtime
- depends = ros-melodic-rospy
- depends = ros-melodic-actionlib
- depends = ros-melodic-interactive-markers
- depends = ros-melodic-std-msgs
- depends = ros-melodic-sensor-msgs
- depends = ros-melodic-geometry-msgs
- depends = ros-melodic-nav-msgs
- depends = ros-melodic-visualization-msgs
- depends = ros-melodic-actionlib-msgs
- depends = ros-melodic-turtlebot3-msgs
- depends = ros-melodic-message-runtime
- depends = ros-melodic-turtlebot3-bringup
- source = ros-melodic-turtlebot3-example-1.2.2.tar.gz::https://github.com/ROBOTIS-GIT/turtlebot3/archive/1.2.2.tar.gz
+ makedepends = ros-noetic-catkin
+ makedepends = ros-noetic-message-generation
+ makedepends = ros-noetic-message-runtime
+ depends = ros-noetic-rospy
+ depends = ros-noetic-actionlib
+ depends = ros-noetic-interactive-markers
+ depends = ros-noetic-std-msgs
+ depends = ros-noetic-sensor-msgs
+ depends = ros-noetic-geometry-msgs
+ depends = ros-noetic-nav-msgs
+ depends = ros-noetic-visualization-msgs
+ depends = ros-noetic-actionlib-msgs
+ depends = ros-noetic-turtlebot3-msgs
+ depends = ros-noetic-message-runtime
+ depends = ros-noetic-turtlebot3-bringup
+ source = ros-noetic-turtlebot3-example-1.2.2.tar.gz::https://github.com/ROBOTIS-GIT/turtlebot3/archive/1.2.2.tar.gz
sha256sums = c652438109ea99008f6d2e950e6cb7f6e67653b8daa1079c825b77d9f52a4e1d
-pkgname = ros-melodic-turtlebot3-example
+pkgname = ros-noetic-turtlebot3-example
diff --git a/PKGBUILD b/PKGBUILD
index 2880cf02b7e5..db9ac5cf0904 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@ using interactive marker, move and stop using LDS, move to goal position, move
to custom routes."
url='https://wiki.ros.org/turtlebot3_example'
-pkgname='ros-melodic-turtlebot3-example'
+pkgname='ros-noetic-turtlebot3-example'
pkgver='1.2.2'
arch=('any')
pkgrel=1
license=('Apache-2.0')
ros_makedepends=(
- ros-melodic-catkin
- ros-melodic-message-generation
- ros-melodic-message-runtime
+ ros-noetic-catkin
+ ros-noetic-message-generation
+ ros-noetic-message-runtime
)
makedepends=(
@@ -22,18 +22,18 @@ makedepends=(
)
ros_depends=(
- ros-melodic-rospy
- ros-melodic-actionlib
- ros-melodic-interactive-markers
- ros-melodic-std-msgs
- ros-melodic-sensor-msgs
- ros-melodic-geometry-msgs
- ros-melodic-nav-msgs
- ros-melodic-visualization-msgs
- ros-melodic-actionlib-msgs
- ros-melodic-turtlebot3-msgs
- ros-melodic-message-runtime
- ros-melodic-turtlebot3-bringup
+ ros-noetic-rospy
+ ros-noetic-actionlib
+ ros-noetic-interactive-markers
+ ros-noetic-std-msgs
+ ros-noetic-sensor-msgs
+ ros-noetic-geometry-msgs
+ ros-noetic-nav-msgs
+ ros-noetic-visualization-msgs
+ ros-noetic-actionlib-msgs
+ ros-noetic-turtlebot3-msgs
+ ros-noetic-message-runtime
+ ros-noetic-turtlebot3-bringup
)
depends=(
@@ -47,24 +47,17 @@ sha256sums=('c652438109ea99008f6d2e950e6cb7f6e67653b8daa1079c825b77d9f52a4e1d')
build() {
# Use ROS environment variables.
source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
# Create the build directory.
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
# Build the project.
cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}