summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-09-21 17:39:15 -0400
committeracxz2019-09-21 17:39:15 -0400
commita02f182de0c670f428eca7e32da38f1531339c66 (patch)
tree18bde9d56ed114ec12321257ee1fc75a04d2af47
downloadaur-a02f182de0c670f428eca7e32da38f1531339c66.tar.gz
initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD75
2 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9ae1b083acc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = ros-melodic-turtlebot3-example
+ pkgdesc = ROS - This package provides four TurtleBot3 basic example include move using interactive marker, move and stop using LDS, move to goal position, move to custom routes.
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://wiki.ros.org/turtlebot3_example
+ arch = any
+ license = Apache-2.0
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-message-generation
+ makedepends = ros-melodic-message-runtime
+ depends = ros-melodic-rospy
+ depends = ros-melodic-actionlib
+ depends = ros-melodic-interactive-markers
+ depends = ros-melodic-std-msgs
+ depends = ros-melodic-sensor-msgs
+ depends = ros-melodic-geometry-msgs
+ depends = ros-melodic-nav-msgs
+ depends = ros-melodic-visualization-msgs
+ depends = ros-melodic-actionlib-msgs
+ depends = ros-melodic-turtlebot3-msgs
+ depends = ros-melodic-message-runtime
+ depends = ros-melodic-turtlebot3-bringup
+ source = ros-melodic-turtlebot3-example-1.2.2.tar.gz::https://github.com/ROBOTIS-GIT/turtlebot3/archive/1.2.2.tar.gz
+ sha256sums = c652438109ea99008f6d2e950e6cb7f6e67653b8daa1079c825b77d9f52a4e1d
+
+pkgname = ros-melodic-turtlebot3-example
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2880cf02b7e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+pkgdesc="ROS - This package provides four TurtleBot3 basic example include move
+using interactive marker, move and stop using LDS, move to goal position, move
+to custom routes."
+url='https://wiki.ros.org/turtlebot3_example'
+
+pkgname='ros-melodic-turtlebot3-example'
+pkgver='1.2.2'
+arch=('any')
+pkgrel=1
+license=('Apache-2.0')
+
+ros_makedepends=(
+ ros-melodic-catkin
+ ros-melodic-message-generation
+ ros-melodic-message-runtime
+)
+
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
+
+ros_depends=(
+ ros-melodic-rospy
+ ros-melodic-actionlib
+ ros-melodic-interactive-markers
+ ros-melodic-std-msgs
+ ros-melodic-sensor-msgs
+ ros-melodic-geometry-msgs
+ ros-melodic-nav-msgs
+ ros-melodic-visualization-msgs
+ ros-melodic-actionlib-msgs
+ ros-melodic-turtlebot3-msgs
+ ros-melodic-message-runtime
+ ros-melodic-turtlebot3-bringup
+)
+
+depends=(
+ ${ros_depends[@]}
+)
+
+_dir="turtlebot3-${pkgver}/turtlebot3_example"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ROBOTIS-GIT/turtlebot3/archive/${pkgver}.tar.gz")
+sha256sums=('c652438109ea99008f6d2e950e6cb7f6e67653b8daa1079c825b77d9f52a4e1d')
+
+build() {
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}