summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbionade242020-03-08 13:51:18 +0100
committerbionade242020-03-08 14:07:54 +0100
commita2e8b0c430022f9c74a99be0f42ba2abee94b576 (patch)
tree13270d13db808260830a70b99ee24ee4056803f3
parent6ad6738a7683f5b40d7d28ddfa164fabaad9e90c (diff)
downloadaur-a2e8b0c430022f9c74a99be0f42ba2abee94b576.tar.gz
Patch python3 compatiblty
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fc54a909a76..d37074f78ff2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-turtlebot3-teleop
pkgdesc = ROS - Provides teleoperation using keyboard for Turtlebot3.
pkgver = 1.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.ros.org/turtlebot3_teleop
arch = any
license = Apache-2.0
@@ -11,7 +11,9 @@ pkgbase = ros-melodic-turtlebot3-teleop
depends = ros-melodic-rospy
depends = ros-melodic-geometry-msgs
source = ros-melodic-turtlebot3-teleop-1.2.2.tar.gz::https://github.com/ROBOTIS-GIT/turtlebot3/archive/1.2.2.tar.gz
+ source = python3-compatibility.patch::https://github.com/ROBOTIS-GIT/turtlebot3/commit/ddca617172a3549a3077682cd2cf7dc377616e01.diff
sha256sums = c652438109ea99008f6d2e950e6cb7f6e67653b8daa1079c825b77d9f52a4e1d
+ sha256sums = 67678a5af67a9cc2753235fbc78cc2cb57841b63884b5b35599ea32f382fcc89
pkgname = ros-melodic-turtlebot3-teleop
diff --git a/PKGBUILD b/PKGBUILD
index e2fc406e7611..2e3d8bd0fae9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ url='https://wiki.ros.org/turtlebot3_teleop'
pkgname='ros-melodic-turtlebot3-teleop'
pkgver='1.2.2'
arch=('any')
-pkgrel=1
+pkgrel=2
license=('Apache-2.0')
ros_makedepends=(
@@ -27,8 +27,15 @@ depends=(
)
_dir="turtlebot3-${pkgver}/turtlebot3_teleop"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ROBOTIS-GIT/turtlebot3/archive/${pkgver}.tar.gz")
-sha256sums=('c652438109ea99008f6d2e950e6cb7f6e67653b8daa1079c825b77d9f52a4e1d')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ROBOTIS-GIT/turtlebot3/archive/${pkgver}.tar.gz"
+ "python3-compatibility.patch"::"https://github.com/ROBOTIS-GIT/turtlebot3/commit/ddca617172a3549a3077682cd2cf7dc377616e01.diff")
+sha256sums=('c652438109ea99008f6d2e950e6cb7f6e67653b8daa1079c825b77d9f52a4e1d'
+ '67678a5af67a9cc2753235fbc78cc2cb57841b63884b5b35599ea32f382fcc89')
+
+prepare() {
+ cd ${srcdir}/turtlebot3-${pkgver}
+ patch -p1 --input="${srcdir}/python3-compatibility.patch"
+}
build() {
# Use ROS environment variables.
@@ -48,9 +55,6 @@ build() {
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}