summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-13 19:48:55 +0100
committerGonçalo Camelo Neves Pereira2018-05-13 19:48:55 +0100
commitf1c9cae9cb5290b712de7c65ae916350d739dfba (patch)
tree85bc109e625229cb9d0365889b53f5fabee93c43
downloadaur-f1c9cae9cb5290b712de7c65ae916350d739dfba.tar.gz
Update
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD62
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e89187d319d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ros-melodic-uuid-msgs
+ pkgdesc = ROS - ROS messages for universally unique identifiers.
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = http://ros.org/wiki/uuid_msgs
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-message-generation
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-std-msgs
+ depends = ros-melodic-message-runtime
+ depends = ros-melodic-std-msgs
+ source = ros-melodic-uuid-msgs-1.0.6-0.tar.gz::https://github.com/ros-geographic-info/unique_identifier-release/archive/release/melodic/uuid_msgs/1.0.6-0.tar.gz
+ sha256sums = c00cacdbfc12e1cc2715a8531eae1fc69700362b2abab974d03d70de5de6d2b5
+
+pkgname = ros-melodic-uuid-msgs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de477619cc6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - ROS messages for universally unique identifiers."
+url='http://ros.org/wiki/uuid_msgs'
+
+pkgname='ros-melodic-uuid-msgs'
+pkgver='1.0.6'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-message-generation
+ ros-melodic-catkin
+ ros-melodic-std-msgs)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-message-runtime
+ ros-melodic-std-msgs)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/uuid_msgs/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-geographic-info/unique_identifier-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="unique_identifier-release-release-melodic-uuid_msgs-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-geographic-info/unique_identifier-release/archive/release/melodic/uuid_msgs/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('c00cacdbfc12e1cc2715a8531eae1fc69700362b2abab974d03d70de5de6d2b5')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}